Carbide Motion on OSX El Capitan


I recently upgraded my Mac to El Capitan, and unfortunately Carbide Motion does no longer seem to work?
Is anybody else successfully using it on El Capitan?

It starts up fine, connects to the Nomad, but independent if I choose to load a file, or move the axes, it just hangs…

Any ideas?


I upgraded to El Capitan last week and have had no issues with Carbide Motion or my machine.

I have no issues OS X 10.11; CM - 2.0.333

I’m on OS X 10.11 and CM 2.0.314

Only have had a few software crashes when i turn off the spindle on my SO3… i believe it is due to a power surge and will isolate spindle power from my main control.

There have been a growing number of reports for the SO3 and Nomad pointing to the need to isolate the power to the machine from other tools.


I have the same issue. I am running 10.11.2 with CM 350. I tried an earlier version .266 and I could not get it to connect. I wouldn’t mind trying versions 314 or 333.

I am having other issues now as I have been testing with earlier versions of Mac OS. I have a post about it, so I won’t bore you with the details here.


New user here just set up my SO3 using OS10.11.3 and latest version of CM. It worked long enough to print out the hello world logo. I then had to move my machines around powering things down properly of course once I hooked everything back up and when I load CM and try to launch the program all it get is a pinwheel. Doing a force quite shows that the program is no longer responding.

I have removed everything Carbide and power cycled the computer then re-loaded CM and get the same thing. I’m dead in the water until I can get this resolved.

Try rebooting and when the bong occurs, hold down cmd-option-P-R (you’ll need two hands). Hold until another bong and let the reboot go this time.

This cleared a similar problem for me and a few other people.


Thanks for the quick reply! I will give it a shot now.

No worki… any other ideas?

List of troubleshooting steps here:

If they don’t help, contact

I will give that a go and see what happens… Thanks again!

EDIT: Ok, reflashing the grbl seems to have done the trick! I can now home and jog the machine. Not quite sure what I did to make it lose the program but so far it appears to be working and considering I’m not very computer savvy this is good news. I read something about settings for the SO3 in the grbl code but not sure how to edit that. I’m guessing something in the code I copied to a file needs to be taken out? I will sift through and see if I can make sense of it.


Please see: for default Grbl settings.

@sixstring I have had the similar problems with my set up and El Capitan. I could not use my MacPro Tower, but my MacBook Pro works fine.

In order to see your GRBL setting you will need to open the log window in order to see what the settings are.

If you are using version .355 after you connect to your SO3, press the letter “L” to open up the log window.

Then click on the button that says MDI. On the line next to the enter button, type $$ (2 dollar signs) then press enter. In the log window, you should see your settings. I have attached a screen grab of my log window showing the default settings in my SO3.

When I have had issues connecting to my SO3 with GRBL Resource Errors, it usually gets cleared up after a reboot of my computer.

1 Like

Ok, after having to take the week off because of illness, today I was able to make progress! After reading through all of the recommended add ons needed to keep com drops from happening I added the following… Tripp Lite AC line filter for the computer and the power supply for the SO3, ferrite beads on all of the stepper motors, and all power cords having anything to do with the SO3.

Finally grounding all axis of the SO3, I can’t get it to fail now having gone out of my way to get it to do so, cycling the garage door opener, opening and closing computer programs and even charging my self with static electricity and touching the computer and SO3 I am happy to report NO com drops. Im sure this is something that Carbide 3D had thought of but including all of these things in the kit and updating the instructions letting you know why it needs to be done can save a lot of headache.

If anyone would like I can post pic’s of what and how I went about it.


Pics and specifics of what you did would be great.

Thus far, what we have is on the wiki:

1 Like