Carbide Motion stopping mid cut, new Spindle

I recently add a 2.2kw spindle and VFD. Ran a new line for the VFD and used a 14/4 shielded cable for the spindle.

Carbide Motion is pausing/stopping mid cut. I can run the project with no tool and the spindle off and there is no interruption. If I turn the spindle on even with no tool them CM will pause/stop.

It’s not a complete disconnect which is odd. CM will let me hit pause then stop and it will continue working as normal.

I have grounded every rail to earth. I have added ferrite chokes to everything possible and can’t seem to shake the problem.

I have reached out to C3D support, but just wanted to possibly get some solutions from the community if possible.


Sounds rather as if EMI/Induction into the Feed Hold input is happening. Could be proven out by clamping the input (on the C3D controller board) to +5v using a 10k resistor (I think it is this way around, but would be good to get someone else to confirm this). Anything from 1k to 100k would probably be good enough to see if this is the ‘route in’ for the interruptions.
As a thought - are you using the Feed Hold signal out to an external ‘pause’ button? If you are the theory above gets a little stronger.

1 Like

I don’t have an external pause button. It’s odd that it stops and won’t continue even when I hit pause then start. It will only let me hit stop to cancel the program.

I’ve even ran it a few times with the log open and don’t see anything that would stand out to signify anything.

Also, The VFD is not connected to the Motion board either.

This sounds like a general EMI issue. The behavior you describe is exactly how EMI issues have always been for me. I also have a spindle and here is what I have done to mitigate EMI:

  1. I have a usb isolator for the connection to the control board
  2. I have an input filter between the wall and my VFD
  3. My spindle is properly grounded
  4. I used shielded motor supply cable between my VFD and the spindle and properly grounded it with the drain wire.
  5. I run the spindle power from the VFD totally separate from all other wiring.

With all these things, I have no issues. I used to have issues with EMI when I was using a router and this same combination solved it for me.


I have a USB isolator on order. EDIT: My VFD has a built in filter (Optidrive E3) My spindle is properly grounded, but will verify. I am using a properly shielded VFD cable.

I have my spindle power cable running in the drag chain with the rest of the cables going to the Z axis, switches, steppers, etc.

Do you mean you have it separate from all of those? If so, could you show me how you ran it separate?

Try running your power cable outside of your drag chain. You are probably getting interference here.

I can’t get a picture right now but yes, I run it separate via a supporting boom at the top of my enclosure.

Ok, that makes sense. I purchased a larger ferrite for the VFD drive cable. I will try and run the cable away from the other wires in the chain.

If you could get a photo when possible of your cable routing I would appreciate it.


I forgot to add that I have a standard SO3 and I relocated my controller to outside my enclosure when I upgraded to a spindle. Before I did that, I had my USB cable running separately from all other wiring after it exited the right side of the X beam. Here is a picture of my current setup:


My controller has been separate from my XXL from day one. But it looks like the likely cuplrit is the VFD drive cable. I’m going to pull it out the drag chain and see how things go.


I have moved the VFD cable out of my drag chain and created a swing arm similar to what you have shown.

I have ran a few files and have not had any interference so far.

Thanks again.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.