Carbide Motion unable to load a new file

In Mac Carbide Motion after running a g-code file, I am unable to switch the g-code file. I click the load file button, the dialog opens and I can select the new file, confirm the selection, and the dialog closes (Exact same process when selecting the initial file). However, the old file name stays displayed as the currently loaded file.

I have tried running the g-code anyway and it is in fact the original file and not the newly selected file.

This leads me to having to close Carbide Motion, re-open carbide motion, re-home the Shapeoko 3 XXL and then re-zero between jobs.

Setup Information
MacOS High Sierra 10.13.2 (17C88)
Mac Carbide Motion Build: 4.0.412
GRBL v1.1 ( Shapeoko 3 XXL)

Exact same issue here. I have to close and re-open CM to switch files.

@reidfo are you also using a Mac?

Yes I am. Latest version of CM4.

This is a known bug…why it isn’t fixed, I don’t know, you would have to ask Carbide about that one. If you go to another screen, like MDI, then back, the name will be updated. It’s just the name that’s out of date, it does in fact load the file.

3 Likes

I’m seeing the same thing. I also think the new file is actually being loaded, just the name is not updated in the window…

If you right-click in the window, you get a small menu which includes an option to “Reload” which will properly update things.

I’m trying to load a finish toolpath ,had no problem running the rough finish wont load,not a mac

I also experience the same on the Mac but If you go to Run, you will see that the new file name will appear there so you’re good to go, no need to restart but I agree it is annoying and has not been fixed in several versions.

it got fixed for me in the 4.17 (but that’s Windows)

earlier versions had the bug on windows as well

Any legit fix for this? I have the same issue I ran my roughing file with no problems now I tried to load my Finnish file on a 3-D cut and it will not load. I am able to select the file but it never changes from the roughing file name on the loading screen with job info. I have even tried running the file and it is in fact the roughing file. I have also right clicked and tried to reload with no luck. For now I guess I will go to bed with my windows laptop still connected and hope I have better luck in the morning

You could just power off the machine, turn it back on, home and try loading that finishing pass file to see if it loads/displays correctly? The machine’s zero will be kept as long as you don’t reset it yourself, so no risk there.

I’m afraid that the problem with the finishing pass file is that it is too large for Carbide Motion to handle.

Break it down into smaller chunks or optimize it to be smaller, or use a different communication/control program — list of the latter at: https://wiki.shapeoko.com/index.php/Communication_/_Control

1 Like

I was going to reply the same answer but since CM is being worked on now and we now have the BitSetter where the toolpaths are being placed in one file, I would think that Carbide would want to fix this size limitation VERY SOON. Maybe @robgrz and @Luke could comment.

It ended up loading the file. It did not load the entire file though only a portion of it. It ran about 1/3 of the file and then the machine just stopped where it was with the bit just spinning in place touching the wood. The card was showing it as a 14 hour file and when I loaded it and it finally took it was showing it as 89 minutes. It ran for 89 minutes and then stopped. I have tried several different ways to reduce the size of the file (i have it down to around 7 hrs according to v carve) and no matter how I do it it does not load the entire thing and only runs a portion. Is there a way to just break this file down into 4 or 5 parts and then just run one file after another without resetting any of the zeros? That would be my preferred solution. I downloaded UGS and started trying to figure it out but I don’t want to have to learn a whole nother system just to run this one file.

Your zeros are stored in the controller, not the sending software. Choose another sender, home, and run.

1 Like

I’ve already downloaded UGS and re zeroed everything and I just wasn’t comfortable with that software. Obviously it will take some getting used to but I was hoping there was a way to break this file up and still use carbide motion. I went back into my tool paths and I increased the step over to 20% with my .5mm tapered bit to make a smaller file and my cut time is down to 4 hours in V carve. I was thinking maybe I could run it at 20% step over and then run the raster at 45゚ and then 90゚ and hopefully that would give me a good enough Finnish. Even with the step over at 20% and the cut time down to 4 hours I load it into carbide motion and it is only showing a 45 minute cut time so now I’m wondering is there another issue that I’m over looking. It just doesn’t seem to be loading the whole file.

Here you can see I originally ran my 3-D roughing tool path with no issues,

then I loaded the finish raster tool path and it only made it about 25% through, so I tried a another tool path with a 90゚ raster and it did the same thing about 10% of the way through

You can “hand edit” if you’re comfortable with the gcode, but with a workpiece like that I’d be really careful. Make sure you’re always starting at a retract move.

2 Likes

Yeah I’m not good enough to do something like that yet. I can’t read G code without a list of what each thing means. I tried running the roughing file again on a new piece of wood using UGS and for some reason my cut depth was over around 3/8" with each pass. I checked my file in V carve and my depth is set at .125 so I just shut the whole thing down. I have no idea what’s going on at this point but it’s super discouraging to have all these issues after a full year with minimal problems. I just cut a 3-D file a few days ago without any issues at all using the same settings for my roughing pass and my Finnish.

2 Likes