CC Toolpath issues using .SVG import

I made a post in another thread regarding this issue, however it may garner more interest if made into it’s own thread. For yucks, I decided to import an .svg into Carbide Create (from @Bonch!). CC opened this up just fine, however there are some post import issues I’m experiencing after more monkeying around:

  • Using any of the alignment tools produces a skewed mish-mash of vector results.

  • The only toolpath I can create is a Contour using the “No Offset” outline… no pocketing or inside/outside offsets will work on any of the imported vector objects. No V-Carve toolpaths work either.

I also tried saving the post-imported project into .c2d format, reopening it, and still the same results. I’ve also cloned the imported vector objects and tried with cloned vectors with the same results.

What am I missing?
Is there a setting/operation in CC that needs to be activated?
Is this all that one can do with SVG imported vectors?

p.s. any natively created vectors allow any toolpath in the same CC project.

A screenshot would help.
From what your describing it sounds like you have an open geometry, as opposed to a closed curve.

Now that you mention this, the resultant tool path makes perfect sense. These sure appear to be closed shapes, however closer inspection is required.

Thanks, Apollo!

After closer inspection, there’s nothing visually detectable suggesting “open geometry”. When clicking these vector entities they all appear to behave as “curve” entities, and selecting node edit mode certainly suggests this too. Yet, the only toolpath option is the “engraving” no offset.

I pulled in some library objects to see if there were appreciable differences in vector entities. I couldn’t see any difference with the editing of similar curve entities and was able to create any toolpath I wanted.

This suggests to me there are underlying fundamental property differences in the vector entity data depending on its ancestry chain (intrinsic or imported). I can send the file for others to have a look at the underlying fundamentals.

This post needs a screenshot.
If you can only apply a No offset toolpath to a line - it is “open”.
To fix it you will need to go back to the program it was created in and change something.
Here’s an example:
Notice the Purple line color of the Square and diagonal line- It is an imported shape, and it can only have a “NO OFFSET” toolpath.
The Black lines are closed geometry.

1 Like

As you correctly asserted Apollo, everything imported is “open geometry”:

I hadn’t retained this “Pro Tip” from the online documentation:

The color of the line is a visual indication of the status of the object you are creating. When the line is purple, the object is ‘open’ and cannot have a toolpath applied to it.

note: the exception is it “can” have an engraving/no-offset toolpath

While it appears as a closed object, and behaves like a closed object (in node edit shown below), it’s not a closed object candidate for other toolpath options.

Many thanks for your support, Apollo.