CC530 Weirdness

I was making a vcarving on a table top with epoxy fill and wanted to surface the tabletop today. I created a 30x30 material and a 30 inch circle. I picked the circle and wanted to create a pocket using a 1" fly cutter I have defined in my custom database. The default tool is a #102 and I changed the tool to #601, the 1" fly bit, and the message next to the tool path was “Calculating Toolpath 0%”. That sat there for a long while and finally the circle filled up with what looked like a 102 bit tiny lines. I just went away and let the machine work and when I came back it said the tool path would take 3900 minutes. I deleted the tool path and tried again, same thing. I deleted the project and created it again and the same. Then I deleted the tool path and created it again with the #601 bit and it worked and took 17 minutes to cut. The cut was 0.010" deep with a depth of 0.010" so it would make a single pass with a 1" bit with 50% stepover and 80 IPM, origin in the center of the 30 inch circle.

I cannot reproduce the issue now but I think it was calculating a 30 inch pocket with a #102 bit. When the tool path rendered on the screen it has a moire effect evenly top, bottom and both sides.

Has anyone else had a similar problem?