Celtic Knot - First project, first mistake

I have ZERO experience with CNC machines, and have never used a CAD program, so this could be very entertaining for some of you. I have setup my Nomad 883, run though the basic tutorial. Ran into my set of problem that appear to be common, but thanks to this forum I was able to move forward. My journey is going to be a tale of Mistakes, but hopefully every mistake will lead me to learn something new.

First Weekend Project: The Celtic Knot
Since I have no experience using CAD software what I am using is Adobe Photoshop Elements 13 and MeshCAM’s ability to import graphic files and interpret shades of gray as cutting depths. So here is my first “CAD Design” (don’t hate me)…

There are four shades of gray, therefore there are four cutting depths, the darker the color the deeper the cut.

For stock material I went to Lowes (the closest hardware store) and found where they sell the wood flooring. “Samples” were 25 cents each. The stock material for this first mistake (I mean project) is roughly 4 inches by 5 inches.
Here is a photo after the rough cut…

Here is a photo after the finishing path…

Whoops something went wrong, this doesn’t match my design. After some trial and error what I think I learned is that this is a good example of the “Surface Angle Limit” checkbox option in the Finish Pass. Since the flat (90 degree) surface is greater than the (default) “Surface Angle Limit” of 50, the software did not finish it.
So now I know what that checkbox does, and I lucked into a good recovery. I opened up MeshCam, set everything up again but this time I unchecked that option and unchecked the “Roughing”. With the Nomad 883 already zeroed in, I loaded the new .nc file and let it run again on the same material.
And it worked!