Current state of EMI on the shapeoko

that’s actually what I’m doing currently. Just tonight I switched to a 6 inch cable, isobar dedicated power conditioner, grounded the bejesus out of everything in sight and running CNCJS on the Pi with an optoisolator on the USB port. CNCJS just sees the controller stop responding when loaded up.

1 Like

That’s a pretty extreme case, did you try it without the USB isolator?

Which board rev are you running?

How old is the PSU brick? (they can get low voltage or noisy with age)

1 Like

Did you try a Sinewave UPS?

yup, I’ve got the optical one sent to me by c3d. it’s fine really, it’s been something we’ve been working on for years without no real resolve. Mostly just trying to see if anyone knows anything about the new controller.

no but we’ve tried all sorts of other power filtering and isolation. sometimes it works, sometimes it doesn’t. Mostly just trying to track down if anyone knows anything about the new controller.

If your problem is a dirty power source, I believe a true Sinewave UPS should fix it, for around $220. I don’t know anything about electric so, just a suggestion.

Appreciate the suggestion . Power seems to be fine, it’s filtered, one distinct circuits and I’ve moved houses with the shapeoko a few times with the same issue. For those of us that have the issue, it seems to be the controller picking up interference somewhere during load that causes it to reset. I probably should just get out the oscope and probe the holy hell out of everything while I’m cutting at some point, but I’d honestly rather throw money instead of time at it if C3D has a better option.

1 Like

All of my EMI issues stemmed from two things:

  1. Turning on my DeWalt router and having a disconnect due to (I guess EMI or voltage surge or voltage drop - not sure) magic. I inadvertently solved this by buying the SuperPID controller and used it from the get-go. I found out my SO3 was susceptible to the router power-on EMI issue when I tried it out and removed the SuperPID controller from the system. At the time, I had a pre-order SO3 controller board without the large filter caps.

  2. Static from whatever I was cutting traveling through the vacuum hose. I first encountered the static disconnect during the winter, when the relative humidity of my shed was very low (when you warm up cold air, the relative humidity - RH - drops, and with low RH you get higher static buildup). I would get “random” disconnects when cutting wood.

One time, I was cutting some StarBoard (UHMW plastic) and I was moving the vacuum hose around trying to find a good way to anchor it over my SO3. When I touched the hose, I felt the static buildup and got a little tingle. I didn’t think too much about it at the time, and I then touched the frame of my SO3 for no real reason, just to rest my hand there to watch the machine cut, and it immediately lost connection.

Weird. That sucks. I was able to recover (PITA, but successful) and kept cutting the UHMW plastic. I could feel the static on the hose if I put my arm up next to the hose as it was sucking up the plastic shavings. It was pretty strong actually. That gave me the idea. I waited until the ctting was done for that project, then touched the hose and then touched the frame of my SO3. Disconnect.

Okay, so for me, it is a static issue.

I started by buying the USB opto-isolator. That did not work.

I tried using ferrite beads. That did not work.

I tried using an UPS - APC Smart UPS 1500. That did not work.

I bought some “anti nuisance hose” that is conductive. That did not work until I grounded it properly, and after that, I never had an issue with static disconnects again - unless I forgot to ground it before starting.

I sold that machine and I now have an XXL and a VFD/spindle. I use 4" flex hose with a steel wire in it and ground the wire, and the last time I had a static disconnect was when I forgot to ground the wire. I should ground the wire where it connects to the rest of the system, but I put a “temporary” ground wire and alligator clip right at the point where the hose hooks to my Suckit, so I have to hook/unhook each time I put the Suckit on. I put that “temporary” wire on 18 months or so ago. I’ll get it done right eventually.

Now, I did inadvertently test this not too long ago. I was cutting some wood, and the ground wire came undone. It must have run for ~5 minutes before I noticed, and when I went to hook the ground wire alligator clip back on the ground wire of the vacuum hose, it disconnected.

So, for me, my “random” disconnects were all related to static in the vacuum hose. Hopefully, this may assist you in identifying the nature of your disconnects.


ahh yes, I had a very similar experience back when I was on a plastic vac hose. I ended up buying the rockler grounded vac hose and I also got a dust collection grounding kit that I additionally ran through the vac line. It did help out a fair bit for awhile and I thought I had found my answer. I’m starting to wonder if I just have too much cumulative damage on this poor dude as I didn’t find that solution until fairly late in the game.

1 Like

For anyone interested, I ordered a 6-pack cnc controller last night ( and an rpi-cnc ( to see if I can get my SO3 back on its feet while I wait to hear more about the new controller. One of those hopefully will do the trick.


I ran a ground cable from the Dewalt 611 body to a grounded outlet in my table base and my edit problems went away. I still run my USB through a hub, which Ed helped in the beginning whilst sorting it all out.

My table rests on a base that I use for rigidity and electrical (router and vac control, safety kill switch) and I disconnected the ground when replacing a relay. I hadn’t reconnected it yet and the controller froze twice in two days before I realized I had forgotten it.

Might help if you haven’t grounded it yet. Brushed motors are noisy I think.

1 Like

I understand your frustration, I had the same issue with EMI when I first got my Shapeoko and I tried all the suggestions listed above with no results. Then somebody mentioned using metal screening (like from a screen door). I wrapped it around the top head of the Dewalt router, the control box on the Shapeoko, the USB cable going to my laptop, and because my laptop resides in a cabinet with a separate monitor, I lightly wrapped the screen around the laptop. It looks a little ridiculous but I went from having EMI issues every other cut to zero issues and it’s been running like that for around 2 years. It’s worth a try as it’s not very expensive.


You built a Faraday cage for it, nice.

You don’t have to be an enemy of the state to find a use for one :wink:


I like to call it the tinfoil hat solution


First cuts with the 6-pack CNC controller and DRV-8825 drivers. micro steps is bumped up to 32 and the motors stay ice cold. Wiring was a snap and now my shapeoko is wifi without a pi. I’m grinding through some MDF right now as fast as I can go to see if I can generate some noise (router is on 6!) and so far so good!

Edit, typoed the driver. they are drv-8825


This is pretty cool, so just to clarify is the 6-Pack controller connected to the Rpi CNC by cable? or is that where the WIFI comes in? does that mean if you have an issue with the Wifi that the machine will stop getting gcode?

1 Like

The esp32 controller has WiFi built in, and it can generate it’s own hotspot.
@scratch Please share more details on the new setup. Did you get any of the add-on modules?

1 Like

nope, no pi at all. the 6-pack uses an esp32 as it’s controller so it has built in wifi, bluetooth and it’s own web interface. I just upload gcode through it’s web UI to the built in SD card and cut from there.

1 Like

Right now I just have the optical isolated input module for the end stops and carbide3d probe. I’m ordering the high current relay to be able to control my spindle and dust collector. Tonight I tested with the router, dust collector and CNC all on the same power strip and didn’t have a single hiccup so I’m feeling pretty confident. I’ll have a page up soon on how to migrate to this controller on your S3 once I’ve tested it a bit more.


I couldn’t find info on DRV-8125 drivers, did you mean 8825 ?
Does jogging sound similar to what it did before the upgrade?