Curved lines auto-connecte in all imported .SVG files -- Carbide Create

Every curve is automatically closed with a straight line on all the .SVG that I load into Carbide Create. It shows up as a blue line whereas the intended line is purple. This happens with .SVG files that I do not create, ones that I downloaded from a website. (See Image) The machine duplicates this on the project piece, which looks awful.

Is there a way to correct this? The original .SVG file looks fine when I open it up with a viewer other than CC.

Thanks

You’ll need to expand those open paths to be closed paths — Carbide Create doesn’t support open-ended paths.

Added the following to the wiki http://www.shapeoko.com/wiki/index.php/Carbide_Create:

Limitations:

  • It cannot import open-ended paths. These will be closed after importing by a straight line connecting the first and last points. This can be worked around by expanding the paths in question to represent the desired geometry. In Inkscape the command for this would be: Path | Stroke to Path

You might try using Estlcam for linking open-ended paths. It’s got some powerful features that allow this to happen without redrawing objects. This video illustrates said feature:

@WillAdams

I was able to make this work once. I loaded the image into inkscape, selected the picture, ran the Path>Stroke To Path, and saved as a new file. Opened it up in CC and everything looked great and it worked. Ran the project on the machine and it looked exactly like it should have without those additional lines connecting the first and last points.

Well today I try it again on a different file and it did not work. Did it over again just to be sure and no dice. Tried it again with the original file, that it worked on the first time, and now that one did not work either. Not sure why it worked the first time but now I am back to square one.

Any ideas?

@WillAdams

I just remembered that I did an Ungroup for the first file. I just tried that with this new, different, file and it worked this time. My memory is not what it used to be so I forgot that I even tried that the first time. I will try it a few for times to make sure it works more than once.

Thanks again for putting me on the right track.

1 Like

Added a note:

(Note that this command works on paths, not groups — if your open-ended paths are part of a group you will need to either ungroup them, or sub-select only the path)