Cutting too deep -- endmill #102 only

I’ve been working on a project on my S3 XXL involving lots of bit changes. Everything has been going smoothly, but when I get to a step involving bit #102 (standard 1/8" endmill), it consistently cuts 0.5 mm (20 thousandths) too deep for every Z motion. That is, instead of the first cut being at 1.14, it’s at roughly 1.6-1.7 mm, and the last pass is gouging my waste board by 0.5mm.

Things I’ve checked/tried:
– Rezeroed (several times) both manually and using the continuity probe
– Not losing steps in Z – zero consistently stays where it ought to be
– Collet is tight
– Correct bit is selected in CC
– Correct depths are set for both this toolpath
– Re-measured stock thickness with calipers – 0.125" exactly
– Stock thickness is correct in CC
– G-code is correct: 3 steps down through 1/8" stock – 1.14, 2.29, 3.17 mm (0.045"/stepdown)
– G-code comments acknowledge correct workpiece dimensions
– During the job, Carbide Motion thinks it’s at 1.15 mm depth on the first pass, consistent with the g-code
– Created a new carbide create project, created a test pattern and assigned the toolpath, and saw the same result
– Changed bits and tested other cuts. Those are all fine, but when I switch back to #102, my troubles resume.
– Bit #102 library parameters haven’t changed, and I’m using stock parameters except that I reduced plunge from 18 in/min to 9
– Z-axis belt hasn’t loosened noticeably; it twangs when I pluck it and the router holds its position when I put the weight of my hand on top of it
– Bed is level
– Workpiece top surface (zero) at the cut coordinates is the same as the height/zero where I zeroed the bit
– Checked through half a dozen related forum threads for clues

I’m attaching the .nc file and some screenshots of my settings so you can have a look.
side 2, outline (v2) (129.6 KB)

Thanks in advance for thoughts on what to try next. I’m stumped. Hopefully I missed something simple and you all can spot it!

First of all, thank you for the thorough description.
I have no idea why this problem would occur only with #102, but let’s put that aside for a moment.

  • How do you check that Z zero is correct before running a job ? if you jog manually to X0 Y0 Z0 (carefully) after zeroing, do you end up dead on on the surface ? If so, if you then do the same check but at the spot where the pocket will be cut (north east of your zero from the look of your file), is it still perfectly on the surface there ? That first test would eliminate the possibility of a stock of uneven thickness OR a wasteboard not quite perfectly surfaced.
  • if the Z zero is dead on, next step would be to check for Z calibration: if you jog in the air by one inch, does it move exactly by one inch ? If it doesn’t (within a fraction of a mm of tolerance) it could be that
  • does this happen in single tool jobs with that endmill ? do you have a bitsetter ?

You should eliminate some variables in the equation to pinpoint the pb, so I would first try a single tool job, without using the bitsetter if you have one, and cutting a single small test pocket centered on the zero point, see if you can reproduce the issue that way.

Now I’m doing what I shouldn’t do, posting this when it’s midnight here and I’ll go to bed soon so I won’t be able to follow up, but I’m sure others will chime in soon


Hi Julien,

Thank you! Your first suggestion was right on. I thought my wasteboard was level, and I was wrong. I must’ve adjusted something in the gantry since the surfacing the wasteboard a few weeks ago.

That the problem was only showing up on my #102 bit was an artifact of how I was setting up my tests. All of my cuts with the other bits were either within ~150 mm of (0,0) or were only partial-depth cuts such that the greater cut depth wasn’t apparent or readily measurable. I was making v-cuts from opposing sides of the stock to meet in the middle.

I thought I had checked jogging over to the start of the cut and verifying z=0, but I must’ve messed it up somehow before my original post.

In any case, resurfacing my wasteboard solved the problem!

All this is why I’m still practicing on cheap stock…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.