Dedicated computer for Carbide Motion?

(Samuel) #10

I bought a Mac Mini on eBay for $120, and it’s now my dedicated Nomad/Printer machine.

I got tired of plugging and unplugging my main notebook. I also figure that the Mini can be more readily sacrificed to the potentially dusty environment.

2 Likes

(Frederic Detienne) #11

I installed bCNC on a beaglebones black. Files are accesible from a samba share so no ftp’ing stuff over. Quite happy with it.

Notice that meshcam generates M6 (tool change) and G1A0000.0 commands that must be edited out. I will write some cleanup scripts for that.

0 Likes

#12

@TotallyFred, what MeshCAM postprocessor are you using?

You can have MC not generate the rotary axis commands. There will be two lines in the postprocessor file like

FIRST_FEED_RATE_MOVE = "G1[R][X][Y][Z][F]"
FEED_RATE_MOVE = “[R][X][Y][Z]”

Change them to

FIRST_FEED_RATE_MOVE = "G1[X][Y][Z][F]"
FEED_RATE_MOVE = “[X][Y][Z]”

and the A000.0 should not appear in the gcode.

For the M6 (MC puts in an M6 every time it encounters a new tool number) you can comment out that line in the TOOLCHANGE section of the postprocessor by adding a semicolon to the front. You’ll need to have your tool loaded and zeroed because MeshCAM will turn on the spindle and start moving straightaway.

Randy

0 Likes

#13

@frank26080115

I’m using a TW100 Winbook and a usb keypad without any issues. I posted this a while back.

0 Likes

(Frederic Detienne) #14

@Randy This is very interesting! After your post, I started reading about post processors and this actually addresses a great question that has been bugging me for a while but did not know how to phrase.

I found the doc and googled forums around but I am still somewhat stuck: no instructions for MeshCam for Mac.

After a bit of research, I found the post files in /Applications/MeshCAM.app/Contents/Resources/Posts

When I save the toolpath, there is no option in the dialog box to select a post processor. It is the plain OS-X “save as” dialog. I can see the extension is .nc but I can’t specify a format.

Also, if I create a new post for MC on Mac, where should I drop it ? The /Applications/Mescham package does not seem a great place.~/Library/Applications Support/Meshcam would sound better but I do not know if this is supported by MC. Then again, I am just asking…

Bottom line, to answer your question: I do not know which post processor I am using as I never knew one could specify one (which is probably why it flew under my radar). :smiley:

0 Likes

#15

@TotallyFred, I’m sorry, the only Mac I have is a Plus so I have no knowledge of MC for Mac.

But it is weird–even though I have a whole folder of posts, I cannot choose a different post than the one shown:

In the Windows MC help STL Quickstart section it says

  1. Click Save Toolpath to save the toolpath.
  1. Select the name and location of the file.
  1. Select the correct post processor for your machine under Save as type. If you’re not yet sure which one to use select Minimum Gcode Config(*.nc).
  1. Click Save.
  1. Click Done in the Accept Toolpath dialog.

And from my pre-Nomad experience the Save as type dropdown does list all the postprocessors in the folder.

I’d suspect it was a factor of the Carbide3d license, but I can’t even choose Carbide3D-inch postprocessor…

MeshCAM’s help file is a little spotty–the only place I could find mention of choosing the postprocessor was in the Quickstart.

I’ll need to do some digging.

Randy

0 Likes

(Frederic Detienne) #16

@Randy Yep… this is similar to a screenshot I found while searching the web (the documentation does not mention any of that… aherm…)

Interesting you can not select a postprocessor of your choice.

I attached a screenshot of the save dialog (from the Save Toolpath). No place to specify a postprocessor either. At one point I suspected the extension would determine the post processor but multiple posts specify the same extension so that would be ambiguous (and so I suspect this is not what is happening).

I hope Rob (@robgrz ) can shed some light on this… but thanks again for pointing me in the right direction!

0 Likes

MeshCAM7 .nc file output
#17

I think I’m going to call a bug here. I should at least be able to select Carbide3D-Inch as the postprocessor.

I reverted from my Carbide license to the legacy license and regained the ability to choose posts:

Of course that gives up the Carbide-specific menu choices.

So the behavior definitely is connected with the Carbide3D license itself.

0 Likes

MeshCAM7 .nc file output
(Rob Grzesek) #18

You’re right Randy- the Carbide license for MeshCAM locks the post processor to the Carbide post that’s built in. This is intentional to eliminate the ability to produce code that’s incompatible with the Nomad or Shapeoko.

-Rob

0 Likes

MeshCAM7 .nc file output
#19

Oh, that is reasonable, Rob. But even the Carbide3D-Inch post is not selectable, for those of us who work in inches…

Randy

0 Likes

(Frederic Detienne) #20

Hi Rob, thanks for answering.

I can understand the commercial reasoning behind that but the MC generated gcode is incompatible with the Nomad unless CM is used to preprocess it… It’d be really cool to have the option to generate pure Nomad code as CM has its own limitations.

0 Likes

(Frank Zhao) #21

Finally… I got my Nomad 883 Pro and a WinBook TW700

The WinBook is a slow sloth. But it does the trick. Do not expect to run MeshCAM on it, Carbide Motion will work though, just tried it.

It doesn’t do ANYTHING good, can’t surf with too many tabs. The internal flash is as slow as a microSD card. It says 16GB but only has around 9, with 5 free when you first open it.

The cameras on it are garbage.

But it does have the most important thing… a full sized USB port

2 Likes

(David McMillan) #22

I’ve been experimenting with some Intel ComputeSticks lately, to use as “headless” controllers for my 3DP and Nomad.

The Windows-version stick is giving me fits trying to get Remote Desktop or VNC to run properly, so I haven’t been able to try CM on one yet. But the Ubuntu-version stick has proven itself ready, willing, and able to run my 3DP wth Cura, and it even does local slicing and G-code generation surprisingly well.

I don’t expect to run MeshCAM on a stick, of course, but using a network share on my LAN for the .NC files should work quite well (with my heavy-metal gaming rig providing the MeshCAM heavy lifting). I just have to get that darned Windows stick to run VNC properly…

0 Likes

#23

I used to use an Rpi setup with old monitor and mouse keyboard etc… Annoying thing was that I couldn’t work on Inventor in my workshop using this setup so I have devised a system of using the Rpi as a streaming device from my main home server which is running an extra VM with windows and streaming it via ethernet to my Rpi in my workshop. Rpi then handles monitor mouse and keyboard. Means I can run windows for CAD/Cam and also I can use the powerful server for generating toolpaths and CAD work without leaving the workshop :smile:

Massively over complicated and there are bugs… I think it would work way better if I used a compute stick or something

0 Likes

(Tim) #24

Will carbide motion run on a Asus EEE PC with Windows 7 and 2gb Ram? the CPU is only 1.60 Ghz though

0 Likes

#25

Just a thought, and excuse me if it’s already mentioned, has anyone tried the Kangaroo from Newegg? It’s $100 and seems decent. I bought one, stripped down all the crapware from windows 10 and setting it up to run the Nomad and a 3D printer. I have it running through an old ipad for a monitor and a logitech wireless mouse and keyboard. It’s a bit slow but seems to be fast enough. I’ll know when I get my nomad in and have time to test it.

I am doing most of my heavy hitting work on my MBP running parallels and SW15. This would just be for an interface and the ability to set it up and walk away without having to leave my work computer.

I also ran across this and thought it would be fun to build but the cost is over $1000 in parts alone.

0 Likes

#26

I’ve installed Win7 on my EEE PC. Carbide Motion installed successfully however I don’t have my Nomad yet so I can’t confirm whether it will run reliably. I’ll let you know in a couple weeks once my Nomad arrives. :grinning:

1 Like

(Frank Zhao) #27

Will carbide motion run on a Asus EEE PC with Windows 7 and 2gb Ram? the CPU is only 1.60 Ghz though

My WinBook has 8GB of Ram on Windows 8.1 and it’s complaining that it’s out of RAM after loading a large file into Carbide Motion. I disabled Windows Defender and Superfetch, and increased the page file a bit, to get around that problem.

1 Like

(Alan Brown) #28

I have a dell latitude D830, but it’s running Linux (mint).
Just got a 3D XXL used ( assembled but never run), and would like to use the dell as a dedicated laptop for it.
Can motion and designer software run on Linux?

0 Likes

(William Adams) #29

I am afraid that while there was an early build of Carbide Motion available for Linux its development has been discontinued.

Most of the opensource software options do run on Linux though — list of them here:

One product in development which addresses this is Carbide Connect which would allow one to control the machine from a web browser — it was announced a while back, and will hopefully work its way through the pipeline soon.

1 Like