Default GBRL SP3 Settings

Could someone post the defualt GBRL settings for an SP3?

Listed here: http://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/

You can resend the defaults by: http://docs.carbide3d.com/support/carbideupdater/#carbide-motion-v4

For some reason it keeps sending the defaults for the XXL.

Please open up the Log window, then send the defaults, then copy out what was sent and post it here or send it in to support@carbide3d.com — I suspect the problem is just that the screen isn’t updating properly — after sending the defaults try right-clicking in the CM4 window and choosing the option to refresh.

Link to the grbl SO3 defaults:

2 Likes

William,
I thought the same thing too. However my testing suggest otherwise. I flashed the machine again this evening and then sent the defaults via Motion 4 as instructed. I then pulled up the logs and appears to be the default settings for an XXL machine. I went through all the steps a second time just to make sure I didn’t select the wrong machine type from the drop-down menu in Motion 4.

(146): -> $132=80
(144): -> $131=850
(142): -> $130=845
(140): -> $122=400
(138): -> $121=400
(136): -> $120=400
(134): -> $112=5000
(132): -> $111=5000
(130): -> $110=5000
(128): -> $102=40
(126): -> $101=40
(124): -> $100=40
(122): -> $32=0
(120): -> $31=0
(118): -> $30=1000
(116): -> $27=5
(114): -> $26=25
(112): -> $25=2000
(110): -> $24=100
(108): -> $23=0
(106): -> $22=1
(104): -> $21=0
(102): -> $20=0
(100): -> $13=0
(98): -> $12=.01
(96): -> $11=.02
(94): -> $10=255
(92): -> $6=0
(90): -> $5=0
(88): -> $4=0
(86): -> $3=6
(84): -> $2=0
(82): -> $1=255
(80): -> $0=10
(63): -> M56P1
(62): -> gc_probe
(60): -> gc_sync
(58): -> N0 G4P0.005
(57): -> gc_wait_for_idle
(44): -> $#
(43): -> gc_get_offsets
(40): -> $G
(39): -> gc_parser_state
(37): -> G90
(36): -> gc_not_motion
(34): -> G49
(33): -> gc_not_motion
(31): -> G21
(30): -> gc_not_motion
(28): -> G10L2P1X0Y0Z0
(27): -> gc_not_motion
(25): -> G54
(24): -> gc_not_motion
(22): -> G92.1
(21): -> gc_not_motion
(19): -> M05
(18): -> gc_spindle
(16): -> N0 G4P0.005
(15): -> gc_wait_for_idle
(12): -> gc_wait_for_status_updates
(7): -> $X
(3): STATE: SET MACHINE STATE: INIT
(2): -> GRBL_RESET
(1): STATE: SET MACHINE STATE: NOTCONNECTED

Blockquote[quote=“WillAdams, post:4, topic:9857”]
Please open up the Log window, then send the defaults, then copy out what was sent and post it here or send it in to support@carbide3d.com — I suspect the problem is just that the screen isn’t updating properly — after sending the defaults try right-clicking in the CM4 window and choosing the option to refresh.
[/quote]

Everything should be the same except the max travel.
$130=425
$131=465

1 Like

In that case, I suspect the drop-down menu isn’t working correctly.

Please try refreshing the window, (right-click on an empty area and select refresh), then making the selection, then sending, and see if that helps this.

I’ll give that a go tomorrow. Promised the kids I read them books before bed

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.