Desperately need help, someone run a file for me

I have a simple project that simply refuses to run properly on my machine. It has failed 10 out of 13 times. Carbide is assisting me but no luck so far. I have changed the design, started from scratch, adjusted all the bit parameters, run it in air with no material, dismantled and reassembled my machine’s head. All to no avail. No problems show up in CAMotics.

I am looking for someone to run the same design on their machine.
If some one else can run the file successfully it will point to my machine rather than a design flaw in the file.

I am using the latest loads for Create and Motion

There is a pocket on the lower right with a little notch on the side. It will take 4 or 5 passes to machine the pocket out and then at the end of one pass, not the last one, the Z depth on my machine gets adjusted wildly.

Dice insert Rev 5.c2d (88.3 KB)
Dice box insert Rev (72.9 KB)

Can you tell us what is going wrong? I’ve run this through camotics (my machine is down with a broken switch).

1 Like

I’ve been having problems with the Shapeoko doing crazy things like yours, plunging down through the work piece, doing random erratic cuts not following the toolpath. Everything looked good in CAMotics. The problem was getting worse to the point I could no longer home the machine and I was getting communication errors. I’ve been exchanging e-mail for the past week and scheduled for a video chat on Tuesday. Nick at Carbide identified one problem that has at least partially resolved the issue. The Z switch was not working properly, it was getting stuck on. I cleaned it and it appears to move and switch on properly. I’m running test cuts. Hopefully this has resolved this issue but a new switch and possibly a controller may be required.

Maybe you should also check that the switches are operating properly.

Run an aircut. Does it still have issues?
Gcode is generally pretty simple. The machine will attempt do what it’s told.

Switches seem OK, I can run almost any other file with no problem.

I have run it in air twice with no problem but I need to run multiple times to be sure. Will try.

Unfortunately I would not be able to run this job on my machine, I just tried a file that worked great last week and it failed again, looks like there is a problem with the X axis at the moment, I just tried it now and it appears that I get a different registration between the Rough-in and detail passes and even within the detail portion, it seems that I the endmill does not pass at exactly the same place for each pass. Don’t know if it is missing steps, something is loose I have not found yet or if the controller is acting up.

I describe what happens in the last paragraph. Once the Z axis is off it starts cutting at the wrong depths and pluges right through the bottom of the material.

Plunging through the bottom of the machine was mentioned in another forum post, maybe you’re having a similar issue:


@carlton220 Sounds like a loose Z belt or loose Z pulley.

1 Like

I have dismantled the head, checked all tensions and pulleys no problems. I can cut holes all day long using other files with no problem it is only this file and only that one pocket that fails.

I thought it may be the retract height also so I repositioned the router in the clamp and moved the bit to ensure that the Z axis could move above or below the entire design freely. I can cut any other pocket of the same depth and cut out contours of material of the same thickness with no problems.

When the fail happens the machine is no where near any limit switches.

It is only this one design and that particular pocket that fails.


I ran again with just a pocket. I noticed that at the end of a pocket layer cut the bit retracts and rubs against the corner as it does so. I can actually see the outline of the bit in the corner. On deeper cuts the force on the bit on this retraction must increase. On the last failed run I heard the z axis belt slip as it retracted.

I thought this belt was tight, it seemed tight to me, but obviously not tight enough.

I tightened the little screw that pushes down on the tensioning belt and really crankened it down. The belt is really tight now and I have successfully made a pocket cut that failed before.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.