Disappointing, to say the least, in my SO3

After researching it for a while, I purchased the Shapeoko 3 because it seemed easy to use. I have had the machine together for a few months now and have yet to complete a project. Carbide Motion seems to run into an error and shut down every time I run a project. It’s always at different times and on different projects. I suspected that MeshCAM may be the issue or may be a secondary issue. It also seems to shut down, especially now that I have “upgraded” to Windows 10.

I am fairly good with computers, but I am completely new to CAM. I have fixed the vertical axis belt problem, but I am still having trouble with something as simple as machining a name 0.1" deep into a piece of wood.

I have a Surface Pro 3, MeshCAM V6, and Carbide Motion V 2.0.314. Does anyone else have these issues? I have the dewalt router with a 1/8" end mill.

Any advice or help would be appreciated. Should I switch CAM software? Reinstall them again?

Hi timgreeson, I think it will be near on impossible to diagnose without more details of the error. Can you post a screenshot or at least the details of the error?

I’ve used carbide motion for nearly a year now on my Nomad with no issues at all. Seems to be very stable software to me. That said I run windows 7 not 10.

That CAM workflow should work. Have you verified/previewed the file? http://www.shapeoko.com/wiki/index.php/Previewing_G-Code

There have been reports of crashes and other issues — AFAIK these all get resolved eventually — have you contacted support@carbide3d.com ?

You could try another comm / control program: http://www.shapeoko.com/wiki/index.php/Communication_/_Control — I’ve had good luck w/ bCNC: http://www.shapeoko.com/wiki/index.php/BCNC

Most likely your problems are electrical — ground the parts of the machine in a star topology to a good ground — further suggestions: http://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

Before giving up, let’s start with the basics - check your power. if you don’t already own one, get a neutral/ground checker and check your outlets. If a problem is indicated, that must be dealt with - some of the problems are potentially fatal - and cause untold problems.

Carbide Motion V 2.0.314

This is considered ancient. Please download version 349 for Windows.

I suspected that MeshCAM may be the issue or may be a secondary issue.

I must say that MeshCAM almost definitely not involved in this/these problems. MeshCAM generates G code from your CAD design. Carbide Motion (CM) takes the G code and sends it to the SO3. It’s nearly impossible for the generated G code to cause a CM crash. Also we’ve got a great many MeshCAM users - Windows and Mac - and there are no reports of MeshCAM generated crashes in CM.


FWIW, the only instances I’m aware of where G-code previews correctly, but doesn’t instruct the machine to attempt a matching cut are caused by limitations in Grbl:

  • line length (50 or 70 characters) being exceeded by too-many places after the decimal point — post-process the file to remove them (I use a GREP in Scite, but there are tools for this listed on the ShapeOko wiki)
  • G-code which Grbl doesn’t understand — use the correct post-processor

Thanks @WillAdams!

Since he’s using MeshCAM neither of those situations should exist.

That said, his reported version is way behind the current one (314 vs. 349) so it needs to be updated and retested. Let’s hope that moving to the latest improves the situation.


If it’s Carbide Motion that’s giving you the error then it’s not likely to be a MeshCAM problem. The only thing to be aware of in MeshCAM is to be sure to pick “Carbide 3D” or “Shapeoko” as the file type when saving the gcode file.

What’s the error that you’re getting in Carbide Motion?


Official statement by Carbide3D:

‘’’’‘USB disconnection’’’’’ — http://carbide3d.com/blog/2016/disconnect-problems/ [http://www.shapeoko.com/forum/viewtopic.php?f=5&t=7536&p=59361#p59361]