Disconnection from cutter after job completes

I know there are a few threads regarding cutter disconnects, but mine is not so random. I recently upgraded the system to 1.5kw water cooled spindle, with custom built pc (powering the closed loop water system) and a touchscreen controller from ‘Integrity first, Quality Assurance’. Building the new pc, I had to install Carbide Motion build 566. … Now I would have bought the shapeoko spindle, but didn’t know they were making one until I was already 500 clams into this one!)

Here’s the oddity:
I do not have the VFD/PWM speed control turned on because I like the manual control as part of my routine before cutting. The machine makes it through the program, but if I do not hit stop on the VFD controller during the spindles final retraction, Carbide Motion disconnects from the cutter. If I leave it running, or dial it down to 0, it disconnects. I have to power cycle the CNC machine before it connects again and then CM displays the final ‘Please turn off spindle’ message from the last operation. When I try to connect without turning it off, it says the something about the Port not having GRBL or ‘something’ not found on the COM port. (I’ll have to screen capture it next time I am making sawdust.) Initializing the Machine after every little program is going to wear out my bit setter.

I read about static- (lol). I used a grounding wristband from work to give the machine more grounding and at different attachment points. Still problems.

I still have the old mac with older version of CM I can try… If it is a bug with 566?

I read about usb isolator and am wondering if that is still a solution. I tried 3 usb cables with and without the ferrite ring, insulated, etc…

Did you ground your spindle? Many 3rd party spindles have no ground and static usually causes usb disconnect. Many have had to run a ground wire from the spindle to the frame. It could be noise from the VFD but that is a more complex thing to diagnose. So if not grounded ground your spindle and see if the symptom improves.

It’s a four pin aviation plug, one pin being a “ground” and connected to the vfd controller ground.

Unless you take apart the connector on the spindle, you don’t know that the ground wire is actually connected to anything on the spindle. Check continuity from a known ground to the spindle.

1 Like

I am pretty sure it is connected- I had to do the soldering to the aviator plug pins and did such a bad job on the first one, I had to get a replacement from cncshop and frankenstien the seating nut from the old plug for it to seat on the spindle (different threads). I followed a youtube video, matching the pin numbers to wire color for the 1.5kw spindle.

I also tried a direct ground using the alligator clip on the spindle body to a nearby outlet ground, (using the ground plug that came with my anti-static mat). - The mat is used for my digital scales for reloading.

I think that if it was static, it would occur when there is the greatest chance of it happening- when the bit is in the wood and dust is getting sucked by sweepy into the Festool anti-static hose. I tried with no hose as well- using my DC that is across the room/ on other circuit and following it around to suck up the shavings.

It is consistently happening at the end of the program, between the retraction and it going back to home, after each run. Doesn’t matter if I do a 2mm deep cut for 10 seconds, or a contour operation for 20 minutes. Only when I hit stop on the VFD in a certain timeframe will it stay connected.

You mention having an old Mac with Carbide motion on it. I would swap that in to see if the problem persists.
If not, then you narrowed it down to the new PC and install of carbide motion.

Wild thought : could it be a mechanical interaction between the movement to home position and the USB cable, depending on how you routed it? I guess it would also happen on initial homing though. Still worth checking that the USB cable is secure.

If not, this may still be EMI from the transition from full power to zero RPM, it would be strange that it only ever happens at that moment, but EMI gremlins are strange creatures. Did you try plugging the VFD on a different outlet?

It’s weird… I have the cables routed away from anything moving, coming up from the back of the cnc cart. The pc sits in the bottom drawer and all cables are routed out the side, and to the back and up to the machine/ screen.


Kinda dark, but everything is black anyway-

That loose usb hanging there is the original that came with the machine and isn’t connected. I need to remove the back panel for the ferrite to fit so I can pull it out.

I have a batch of things to make this week and will be doing some more component testing as I cut them. I don’t think I tried separating outlets and I can put the pc/cnc on one circuit and the vfd on its own. I’ll be giving the mac with older CM a try too.

1 Like

Moving the vfd to its own outlet and separated circuit from the rest of the setup resolved the disconnecting problem. I ran 7 jobs without a problem (identical program/ pieces for about 45 minutes), and then on the 8th run at 98% complete, the cnc just ran the bit right through the project. Ain’t nobody got time fo dat. Had to hit the red stop/cancel button in CM and an error popped up that the ‘Machine controller restarted unexpectedly and may be in an undefined state.’

This is too flaky for my patience and I’m thinking of removing the spindle and going back to the jet engine screamer of a router.

Put the old router back in today and ran no issue for all 12 programs. I will add that the first three-four times I was initializing the machine, it would randomly stop and grind away. I would hit the power button to stop it and checked the belts/ wheels movement and didn’t see debris. Fired it up, jogged it to a few places and it would randomly stop and grind. Took out my phone to video it, and it wouldn’t do it. It was like it was discharging pent up electricity. Nothing VFD or spindle was touching the machine.

On another note, the parts cut with the router are true to size whereas the parts cut with the spindle are short ~.60 mm. I figure this has something to do with the weight of the spindle. I had adjusted the drawing to match the spindle and forgot to check it before running the router so they are a little loose but still legit.

So if anyone wants a 1.5kw water cooled spindle that comes with power cords, extended controller cord, and whatever else I can find that goes with it for s steep discount, maybe it’ll work better in your set up.