DLL files missing newby getting plenty frustrated

Ok so I ordered an XL, and after several hours of reading IMO pretty poor instructions I finally got the thing put together
I slapped a piece of paper down tied on a marker, and thought hey this is too easy. I was right. snapped the tip off the
marker running the Hello World program, and thought well first instincts were right it was too easy. I started looking online
and playing with the motion settings. I finally discovered I plugged in some wires in the wrong spots, and corrected it.
I started setting up to Home the machine with the switches, and discovered I had those in the wrong spots. As I was
chasing the wires through the drag chain to make sure I got them correct my computer began updating itself (Windows 10
I hate you). I let it update, and afterwards I tried opening Motion, and started getting .dll missing errors. I uninstalled motion
several time, restarted the PC. Downloaded what I could from Microsoft, and uninstalled Motion and re-installed a few more
times. Seems like the universe is telling me I am not cut out to operate a CNC. I am about at the end of my rope. I am not
buying a new computer just to run the machine, and I can’t seem to get the program to work because of the missing .dll
file thing. Any fixes?

If it’s msvcp120.dll we have an article on it here: http://docs.carbide3d.com/article/74-missing-msvcp120-dll

If it’s a 64-bit machine, you may need to install the 32-bit version of the libraries: https://www.microsoft.com/en-gb/download/confirmation.aspx?id=40784

Some folks have had to install the .NET libraries: https://www.microsoft.com/en-us/download/details.aspx?id=48130

If you’d let us know which DLL is missing maybe we could be of more help.

1 Like

First it was the MSVCR120, and after reinstalling the first time it changed to the MSVCP120, and after uninstalling and re-installing it’s back to the MSVCR120.

Microsoft has a link on this:

https://answers.microsoft.com/en-us/windows/forum/windows_8-hardware/missing-msvcr120ddll/28b03b3b-1d15-4e47-ba31-8ace6920b9ba

which suggests this link:

then scanning your system:

http://support.microsoft.com/kb/929833

Hopefully this will get you connecting again.

Tried all that with no luck. I wonder if I just reformat the computer if that will work. If not I think I can get some trigger time in on the range with the thing.

Can you restore the system back to a point where things worked?

If not, my suggestion would be an inexpensive tablet — safer in the workshop w/ all the dust.

OK reformatted the PC. re-installed everything, and so far it works. Hopefully it will stay that way. In hind sight I think it may have had something to do with the automatic update coming on while I was in the middle of homing the machine. Don’t really know, but it works for now. Also I got the Hello World to work. If I had one suggestion for the Carbide folks it would be to dummy proof the wiring for idiots like me.:joy: I must have changed the homing wires 20 time until I got it right. I know noob problems.

2 Likes