Dust collection hose causing machine to halt?

I have to say I’m very disappointed. After a couple emails with support the solution is to buy a new control board. I’ve had this machine for a little over a year and it has less than 10 hours since I just recently starting getting back into it and I found out one of the main components is malfunctioning. Not just that but it’s the electronics board…these shouldn’t go bad, if they are made of quality parts these last a very very long time and it’s the first thing to go. Ugh. To boot, I’ve been given no idea why this has happened or if it will happen again so I’m just stuck buying a new control board and hoping the quality on this one is better. That, or try to sell this off as parts since it’s useless without a control board and get another brand. :pensive:

Does it home ok?..

A usb isolator solved my disconnect issues. I run my vacuum and router on one outlet and the machine in another. They might all be on same breaker.

I also use an antistatic hose from rockler. But i think I purchased that after my disconnect issue was solved.

1 Like

Most of the time, but now just connecting causing the “door open” message to appear.

Can you open the log and copy paste some of the lines here?
Which board version do you have?

Board is 2.4e, I already took the board out anticipating the new board I had to order so I can’t pull logs. Maybe if I have some time today I’ll put it back but since I already ordered as new board to get back up and running there is probably no point.

So, interesting enough I plugged in back in to get the logs for neilferreri and everything is working fine. Given the board is just dangling but I just ran the init process four times and I didn’t see the “door open” message once where as before it happened just about every time. It didn’t appear any connection were loose (nor is it clear that would cause the issue) but I did just reconnect them all so maybe that was it? Could there be a short when it’s connected to the heat sink, could it be an EMI issue when it’s attached to the frame? So many questions now, I already ordered the replacement board but I’m going to continue to debug this to see if I can run a job with it not connected to the frame.


Where is your router plugged in compared to your computer and control board power supply? Are they all running off the same outlet/power strip? Did you run the router cord through your drag chain?

Computer(laptop) and machine are running off a surge protector connected to the same circuit as the router but yesterday the router wasn’t even part of the equation and it was still failing.

I don’t have a drag chain

Keen to hear if the new board solves the issue. Definitely a head scratcher…

So, this just happened. I hooked it all back up, I put teflon tape and thermal paste on (there was only a stick) and ran some test jobs with no router and that worked so I hooked the router up and ran a quick square job. Not a single issue, cut perfect. :face_with_raised_eyebrow: Good thing I have that new board coming… :woozy_face:


More updates. I’m 15 minutes into a 25 minute job…not a single issue yet. It’s good news but it’s still frustrating I have no idea what was going on and if it will happen again. I’m a little disappointed supports first instinct was to basically tell me to buy a new controller too.

Well, if I was there on site troubleshooting that problem (:smiley: ), I would say that you had a wiring connection problem and solved it by reconnecting in a different/better way.

One initial thing to do is always pull/push connections that are slip on style. Then do the same with screw connections.

But having pulled the board, I would have gone back with a soldering iron and resoldered all the pull/push on connections at the board. Cold solder joints are famous for working after one moves them around, but just you wait. They’ll come back sooner or later. It is always more difficult to solder to externally mounted components in a production run of PCBs.

Just my 2cents.


Yeah, it has to be something like that but it seems odd that a loose wire would cause that kind of issue (door open and stopping the job completely). I just ran two 30 minute jobs without a single issue, going to queue a few up and keep this thing working to see if I can get it to fail again. If it happens again I’ll probably solder the connectors and maybe even direct solder the wires to the board.

@RyanD I just saw this… Excellent! Like I said, the logs surprised me as I expected to see your inputs activated. It really sounds like you had something on the board or it was a wire connection.
Glad you’re up and running! :crossed_fingers:

1 Like

I’m ready to give up. At the recommendation of Carbide I replaced the board and it’s still locking up. I’ve followed just about everything I can on the wiki, new usb cable, grounded and separated wires and it’s still stopping every other job. I don’t know what else there is to try, it’s frustrating I have a $1400 machine that the only support I can get are some tips on a wiki and strangers on a forum guessing.

Guessing-stranger here:

  • you worked a lot on fixing the machine itself, but unless I missed it in the thread: did you try to use a different computer ? a different USB port on the computer ? Adding a powered and isolated USB hub ?
  • you may want to try a different G-code sender ? Obviously a different G-code sender will not make the EMI problems disappear, but they react slightly differently to spurious comm issues.
1 Like

Yeah, I tried a different computer (desktop vs laptop) and the same thing happened so I ruled that out. I was only using Motion as the software but again, two different versions( Mac and Windows) so unless there is a major bug it’s not the software. It’s not the gcode as this has (and continues to happen) on different projects.

The last thing we heard from you was on 6 February when you noted things were working well.

I have just sent you our numbered set of EMI recommendations in a note where we’ll hopefully resolve this.

There is one further thing we’d like to do — we’ll work that out through support@carbide3d.com if that’s acceptable?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.