DXF Import from Onshape

#1

I’m trying to import a DXF file into Carbide Create but keep getting the following error.

Lua Error:
[string “dxfreader.lua”]:641: bad argument #1 to ‘pairs’ (table expected, got string)

The design was exported from Onshape. I’m able to open the DXF in eDrawings and a couple of other free CAD programs like DraftSight etc.

Does anyone have any ideas on how to make the compatible with Carbide Create?

0 Likes

(William Adams) #2

Best technique for this seems to be to open the DXF in Inkscape, check and adjust as necessary (ensure that all paths are closed, convert strokes to expanded paths, &c.) then save as an SVG and import that.

0 Likes

#3

I tried opening it in inkscape. It completes but doesn’t show any geometry. I’m not sure why cad programs can see the geometry ok.

0 Likes

(William Adams) #4

Switch the view to outline mode:

View | Display Mode | Outline

If that doesn’t allow it to show, contact OnShape – also send the file to support@carbide3d.com and hopefully one of the devs can add it to the test suite.

0 Likes

#5

It looks like it opened only a portion of the geometry in inkscape. Basically it left some of the lines out. I’ll contact support. It’s really just a 2d job. I guess I could do it in MeshCam and just do a pencil finish to cut out the items.

0 Likes

(William Adams) #6

Okay, in that case, please forward the file to Inkscape devs as part of a bug report.

0 Likes

#7

Update: I’m not sure how/why this works but this is what I’ve figured out in case it helps anyone else.

Export DXF from OnShape
Import into Microsoft Visio (uncheck all options at bottom of dialog box)
Right click and select option to convert cad file to visio drawing.
select outer bounding box and delete otherwise you end up with 2 layers on top of each other.
Save as autocad interchange (dxf)
Open in CC

0 Likes