Error (1) error in line 20: arc endpoint error?

(Scott Conant) #34

Which post processor are y’all using on F360? I have found that can make a world of difference with these arc errors.

Could give this a try:

@RichCournoyer had one written too, but I don’t have a lot of time atm to look for the link

2 Likes

(Luke) #35

I’m using Carbide3d.cps I have no idea if this is an out dated one?

0 Likes

(Ummm, not sure, but I’ll try...) #36

Thanks. Didn’t even know there were alternatives.

0 Likes

(Ummm, not sure, but I’ll try...) #37

Scott, problem solved. I think. I’ve only run one job in CM 4.410 but no errors.

COOL, thanks again!

0 Likes

(Luke) #38

How did you install the post processor?

0 Likes

(Ummm, not sure, but I’ll try...) #39

Here’s the link I found. https://knowledge.autodesk.com/support/hsm/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-add-a-Post-Processor-to-your-Personal-Posts-in-Fusion-360.html

2 Likes

(Luke) #40

Legend. That was much better than the article I found and could not follow

0 Likes

(Scott Conant) #41

Thx for finding that article Griff. I’ve been busy past couple days with in-laws…lol!

I know installing the post processors are a pain. Took me a long time to figure it out too.

1 Like

#42

I can’t get the openbuilds post processor to work either on cm 4.10… Is there going to be an update to the Carbide3d post processor?

0 Likes

(Ummm, not sure, but I’ll try...) #43

Hmmmmm, I wonder why. I’ve been using that post exclusively for CM 4.410 since my last comment above. Works every time. Just have to get used to it starting the job the instant you hit START (no tool change dialog). I like the fact that when the job is done it just raises the spindle and stays put, no auto home cycle.

1 Like

#44

This is the gcode I produced in F360: 1001.nc (70.6 KB)

If someone gets a spare moment and could see if it loads for them in cm 4.4.10 I would greatly appreciate it!!

0 Likes

(Andrew Kamin-Lyndgaard) #45

nick-

I just ran your 1001.nc gcode on CM version 4.4.10 and received the following error: “ERROR (6): Error in line 56: Bad Arc Format, No I/J”

Reference attached screen shot.

I’m experiencing this issue as well having just updated GRBL and Carbide Motion.

Would welcome solution as community identifies.

1 Like

(Ummm, not sure, but I’ll try...) #46

Tried your file, got the error.

Sorry, don’t know what to tell you. You are sure you are using the f360-easel.cps?

0 Likes

(Andrew Kamin-Lyndgaard) #47

nick-

I just also ran your 1001.nc on version 4.4.07 and received the same error. My file, which did not work on v4.410 did run on v4.407. Both used Carbide3d PP out of Fusion360. My error code did not include the No I/J just the Bad Arc Format when attempting to run in V4.410. May run down the No I/J error and try your code on v4.4.07.

1 Like

#48

ahhh I was using the openbuilds cps file not the easel one! This is post processed with the f360-easel post processor: 1001.nc (326.1 KB)

0 Likes

#49

Even if the easel post works it seems a bit ridiculous if the Carbide3d post doesn’t work with carbide motion… Pls fix this Carbide3d!!

0 Likes

(Ummm, not sure, but I’ll try...) #50

That one loaded ok. But as soon as I hit Run it immediately threw a Door Open error and Limit Switch hit error.

0 Likes

#51

This is so weird… I’m just going to use bCNC until Carbide3d fix this :slight_smile:

0 Likes

(Luke) #52

I’m gonna send another email to C3D - the other post processor does not work. I can’t used CM and probe and have jobs to do :frowning:

0 Likes

(Rob Grzesek) #53

Thanks for posting this code, we’ll try to take a look at it on Monday.

The current build of CM requires both I and J to be defined and this gcode doesn’t do that. We’ll see if we can get it updated quickly.

3 Likes