Error (3): GRBL ERROR: Serial Port: ResourceError - Help!

Hi there,

Just fired up my Nomad for the first time today. I was fearful that the software was going to be the hard part for me, but nay! That part was actually pretty easy. Here’s where I’m getting stuck:

I have a piece of .6mm copper sheet in the machine. I’ve set up everything correctly (or so I believe). It calibrates/zeros fine. Then when I go to begin the cut, the SECOND it touches the metal the USB disconnects and immediately reconnects, but not before giving me “ERROR (3): GRBL ERROR: Serial Port: ResourceError”.

Why is my USB disconnecting when the bit makes contact with the metal? Has anyone else experienced this?

It sounds like electrical noise or ground loop issues. I had this issue briefly when I had the machine and the control computer on different branch circuits.

Check the power and ground connections to the machine and the computer, and insure that they are on the same circuit. You might also try putting a small wire (or spring) to connect the copper sheet to a wasteboard screw, and therefore the machine frame.

1 Like

Thanks for your response. I tried that this morning and it worked for a short time - it made two small cuts okay then when it went to begin a third cut the same thing happened, however this time I have a different error code - “ERROR (8): GRBL ERROR: Serial Port: ResourceError”. It’s error code “8” instead of “3” now. I also noted that when it stopped running I didn’t hear the USB disconnection noise like I did with the previous error #3. Any thoughts?

Please contact us at — we’ll do our best to help you sort this out.

My issue seemed to be an EMI issue. Will was able to send me a short list of things to try to lessen the interference, and it worked! Hoorah. Can’t wait to get creating with this thing.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.