Error 5 GRBL ERROR: Serial Port: Unkown Error


So this must be happening 1 times in 2, its incredibly annoying as you set the job up and then start it, walk away grab a coffee and then return to find its 3 mins in and its died.

I’ve read a bit on it from what i can tell its electrical interferance? Is that right?

I’m using the USB that was supplied with the machine I havent had the vac turned on for the last couple of runs where its failed.

any help with this would be ace


Yes, this is most likely a communication disconnect induced by EMI/static charge build-up.
There are a variety of threads on this topic that you can search as there are many recipes to fight this, but the most popular (/effective) fix is to ground your dust collection hose (wrap a copper wire around its end, and tie it to the the router mount for example)

EDIT: sorry, I read too fast, you did mention the shopvac was not turned on
EDIT2: I collected usual workarounds here:

1 Like

thanks for coming back to me, I’ll go take a read through what i can find.

I just stripped it all back, no vac hose, removed the boot, removed the probe.

Cleared all the wiring away from the usb cable to the PC, reset the job and low and behold the samething happened. it was further through the job than before though so i guess thats something!

I think i might be in for a fight on this one!

Edit: Thanks for that link too, i’ll take a look at those!

Have you disabled Windows’ power saving mode for the USB ports on your computer? This is a common cause of your issue.
John Champlain

1 Like

Unfortunately there is no definitive/deterministic way to tackle such issues, but your best bets are

  • to test various grounding options. If the disconnect happen “often enough”, that is a very good news to have a fighting chance (the very worst that can happen, is that disconnects happen so seldom that identifying the root cause takes forever). You may want to identify a known good ground somewhere in your setup, and hook up a wire with an alligator clip to various (conductive) parts of the machine, you may see the problem going away suddendly, and then you know which part is improperly grounded. The router is a common culprit.
  • if it is very dry right now where you live, try the water spray/humidifier.

Thanks for that, yup, i did that! when setting up! :slight_smile:

1 Like

Thanks for that.

To make a good ground, can i take a feed off of the corner screw on the control board, tap a screw into the y rail and then run wires to that from all the other parts?

@leachr83 What happens if you try a different sender? UGS, CNCjs, bCNC, etc.

1 Like

For the investigation itself don’t bother connecting at the board level, you could just try to run a wire from somewhere on the machine plates, to the known good ground/earth, and then do the same for the moving parts (X/Z gantry, router). Quick and dirty, just to create an evacuation path for static charges, to see if it changes anything (since it can be a completely different thing, there are multiple possible sources for disconnects)

1 Like

I’ve not tried a new sender yet, I’m still pretty new to this. I’ll give that a crack later today or tomorrow

Ok got it, i’ll have a go and see what i can figure out thanks again


I’m still having issues, I’ve earthed the chassis and the router.

I’ve put an APC unit in place to power the shapeoko and computer to avoid any surges

I’ve also put a usb noise surpressor before the USB cable…

I’ve got some ferrite cores coming which I’ll start chucking on the cables and I’m going to earth my work bench too.

anyone got any other ideas?


I’ve not tried yet, bit of a newbie question but which one is best/most user friendly???

On top of trying other senders as Neil said, I would suggest you try to run the job that gives you the issue, as an air job and with the router turned off the whole time. If the disconnects go away, somehow it’s still an EMI issue and something is still not grounded properl somewhere. If the disconnects continue to happen, then it’s probably not EMI (considering what you have done so far to address it)


Contact us at and let us know what you’ve done thus far and we’ll do our best to help.

I prefer CNCjs for most things.

If it’s truly an EMI thing, the sender won’t help. Ruling things out. As @Julien said, running an air cut will help diagnose.

I’m curious to know if a Noise supressor will have any impact on EMI or static discharge. One of the issue with USB is that it loses connection between the computer and the Shapeoko controller. It could be due to an unstable USB on the computer port


I kept getting a disconnect issue that was driving me insane. 50% done with a 2 hour cut time let’s disconnect, restart make it to 94% then disconnect, why not. It takes a lot for me to get frustrated enough that it shows but at this point I took my hearing protection off and whipped it at the bench, the wife just happened to walk into the garage at that moment and she was like WTF I’ve never seen you do that. Long frustrating story short I took some 16gauge (or there about) and grounded everything. Ran a wire from a screw on the router, one from a bolt on the z axis, one from a bolt in the right y extrusion, one from the left side of the gantry, and even used copper tape (or whatever it is called) to tape a wire to the body of my MacBook Pro and ran them all to one of the bolts that holds the enclosure for the board. I have not had a disconnect since then. Maybe try giving that a shot and see if it helps only took about 30 minutes so even if it doesn’t you’re not wasting a bunch of time.

I’ll include photos in case my explanation isn’t as clear as I had hoped.

1 Like

Sorry I’m new so I am limited to 1 picture per post and only 3 replies in a single thread in a row, so I tried to give the most “helpful” pictures.