Errors - Losing connection

Machine - Nomad 883 Pro (SN 297)
Carbide Motion Version - 3.0.357

We have had issues with losing connection to our Nomad 883 with Carbide Motion.

First issue:
Error appears when our air compressor kicks on. (This air compressor is plugged into the same power circuit as the Nomad.)
GRBL Error: DeviceNotFoundError


This stops the program and we have to shut down the Nomad and switch around the USB cable to a new port to reconnect.

Options we have tried:
1- Attaching wire to chassis to ground in plug on wall. (didn’t work)
2- Nomad plugged into Power conditioner. (didn’t work)
3- We have been able to plug the Nomad into it’s own circuit and air compressor doesn’t cause error. (not really a solution)
4- Ferrite core on USB cable from Nomad to Computer. (didn’t work)
5- Ferrite core on AC in to Nomad. (didn’t work)

Second Issue:
Same error appears when we touch any metal part (attached to ground) after the machine has been running. e.g. changing out a tool.
Same Error as above - GRBL Error: DeviceNotFoundError

Can’t find any solution for this problem. Seems like a static electricity problem? Grounding?

Third Issue:
Error appears when we try to reconnect without shutting Nomad off and back on.
GRBL Error: Cannot open port for cutter

Are these issues related? Any thoughts?

If possible, use a different circuit:

http://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

Using a different circuit works for the first issue, but not the second issue. Still get the error, after touching grounded metal anywhere on the mill, when the Nomad is plugged into a different circuit. This usually happens when I have to change out a tool or once a program has finished. We do mill mostly plastic stock, which does generate a lot of static electricity.

If what’s on the wiki doesn’t resolve your issue, contact support@carbide3d.com