Everytime it's different - X axis changes S3!

So I ran the shapoko for a few months this spring and at first it did this but then magically worked for the few months without a hitch.

I downloaded the newest versions of Motion and Create, now this again.

What i’ve tried:

Tightened the X axis belt, but was tight before.
Adjusted the V wheels, needed a hair of tightening
Recreated a whole new gcode with whole new create file from scratch 2 times.
I’m lost and needed to make something for work. Any help would be a blessing! Thank you!!


HERE’S A video password: soda

I guess my question is, is it the machine or the GCode. If you post your GCode, I’ll run it to see if it runs any different. You will also need to post a sketch so I can reference it against.


it’s the machine. Just ran it on wood and it was fine. Here’s the Gcode though:

@ApolloCrowe Is there a way to get an older version of Carbide Motion? The new version crashes 8 out of 10 times. (for me). I’m on a Mac, and the version is 3.0.366

Pick your version:


You will probably have the files in your download folder…

Thank you guys. Just updated the DB files. Should see everything in there.

Just uploaded another video into the same dropbox folder.

Hmmmmm, it ran just fine for me (twice).

FYI Code looks good too.

And you say it runs OK (on the same machine) cutting wood?

The Blair Witch Video is cool

1 Like

Two ideas come to mind. If you stall a motor, it usually skips one or more steps and sometimes continues on it way but it is no longer in sync. You r program is modest in speed and feed so I don’t think’s its stalling. Next would be a bad wiring harness or loose connection. I’d let the program run and start moving the X, Y and Z wires around to see if you can reproduce the error.

Anybody else have a similar problem and know of a fix?

Wiring connections come to mind.
Inspect the board for any visual signs of failure.

Maybe check your grbl settings, open a log window and type $$ on the MDI.

Should be this:
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, m)
$100=40.000 (x, step/mm
$101=40.000 (y, step/m)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)


Are you on El capitan? it could be mac update related.

I WAS on Yosemite and the darn update put the newest Sierra on here. This is the first job i’ve done since that update, so good call Apollo. Now If I can get my old os on here…

Rich, I’ll do just as you said: Wiggle the wires and see what’s up.

Fixed. (hopefully)

I slowed the feed WAY down, and it seems to have fixed the issue. I also slowed how deep it goes in each cut way down, from .7 to .3 mm. She’s running along fine, and no crashes yet. I’ll keep you updated. I’m sure I can fine tune the settings for more optimal performance.

I also changed my endmill from a 2mm width to a .125 width. Breaker bits for both.

All that being said, yesterday it crashed constantly without even trying to cut, but today it’s been solid for an hour without trying to cut. (ghosts) (or prayers are working)

Crashed? As in Disconnects?

Do a quick search on this forum and you’ll find a list of things to try.

What worked best for me? Adding a ground to my machine to the electrical (Green) ground.