Extreeeemly slow "Hello World" Test

I’ve been reading threads for hours looking through “Hello World” and “Homing”, but can’t seem to find a similar problem reported.

I’ve assembled the XXL with Homing Switches. I’ve set the GRBL $22=1. I’ve changed the “Settings” 1005, 1006 and 1007 to TRUE, 850,850.

All jogging, homing and Fast Motion functions work well.

I loaded CM and opened the “Hello World” file.
Performed a Homing.
Set my Zero position with the Sharpie installed tightly and positioned just above the paper.
I select RUN.
I select CONTINUE when prompted for the tool.
The pen lifts and moves to the beginning point and starts the “Shapeoko…” design.

It appears that everything is going to be fine, however, though shaped properly, the “S” of the Shapeoko Carbide logo is drawn soooo slowly that it would take forever to complete the project. I just hit PAUSE and ended the job. I’ve tried three times with the same results.

It’s as if it is “microstepping” through the drawing in 1/10th second increments.

I just drew a three inch square in CC. Sent it through CM with same results an extreeeeemly slow square.

Any ideas would be greatly appreciated. Maybe I’ve missed some other setting changes somewhere?


There has been at least one other report of this — that other instance solved itself when the person rebooted and reconnected or something similar.

Please check your Grbl defaults, as well as the settings in Carbide Motion’s preferences. http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings

If everything seems correct, then please contact support@carbide3d.com and someone who knows more than me will help.

Hey William,

As usual, thank you for the quick reply.

As a matter of fact, I edited this post after going back out to the shop, drawing the square and giving it a try. Both the computer and the XXL were off for a while.

I checked the GRBL settings line by line when I first found the problem with the “S”. Every line matches the default settings with the exception of $22=1 and $130 and $131 both = 850.

Guess I’m stuck writing to Support. Haven’t had much luck there.

Thanks again for the reply.

When you write support, also please include the specifics of your computer system setup.

The differences you noted ($22 homing on rather than off, $130 and $131 XXL rather than SO3 bed size) are correct for an XXL w/ homing switches installed and enabled, so that wasn’t it.

I suspect it’s something in Grbl or how Carbide Motion interacts w/ Grbl — it feels as if buffering is turned off or not being used for some reason — try a different comm / control program to see if it’s CM or Grbl?

List of them here: http://www.shapeoko.com/wiki/index.php/Communication_/_Control — Universal G-code Sender (UGS) is preferred by folks who don’t mind Java and like nice, new appearing software, while bCNC is preferred by folks who like Python and don’t mind old-school blocky-looking software.

Thanks William,

Email sent. I’ll give UGS a shot tomorrow.


Did you happen to have the Log window open?
Leaving the LOG window open will result in a slow running job.

1 Like

@willadams, @ApolloCrowe

Thanks guys. That must have been the problem. All seems well after a retest with the Log window closed.

The Log window was still open because I had just finished changing the $22, $130, $131 GRBL Homing settings. I then Loaded and executed my gcode file. I remember the Log window seemed to be echoing steps one at a time, but I didn’t pay any attention to what was being displayed. Not that I would have been able to tell that that was linked to the slow speed.

Note: I didn’t see anything in the documentation stating that the Log window must be closed before selecting Run. Maybe in the next update of the CM Users Guide, that could be inserted in the section covering the RUN button, as there is no coverage of the Log window other than a Screen Shot between “Full Screen” and “MDI”.

Thanks a million to both of you.

I added a note in the Hello World instructions and to the wiki: http://www.shapeoko.com/wiki/index.php/Carbide_Motion_Machine_Control_Software#Known_Issues

Hopefully I’ll remember this in the future (feels wrong to me, since I’m very accustomed to leaving the log window open when typesetting TeX files).