Finding Center again after power Outage

I have asked this before and did not get a answer that i either can understand nor can reproduce.

2 Scenarios, either the power went out, or i make a mistake when sizing the piece, the shapeoko goes to far to one side and the belt skips, but either way the Zero is not Zero.
I power off and on and tell it to go back to zero and its off, either a small amount or large.

I did not write down the coordinates so how do i go back to zero of my piece?


The zero should be preserved based on the homing offsets — so long as you don’t change the endmill it should just work.

I always set zero at one of the rapid position points when feasible — usually then it’s obvious where I started at.

If neither of the above works, then you need to re-establish you zero based on some reference on the partially cut stock — is there some point you can measure from unambiguously?

If the belt skips then the zero is off even if its preserved, thats what happened to me today. When the CNC finished it went to the back of the piece and i heard it go beyond the limit switches and heard a grinding which is the belt skipping, when i re-zero it ifs off but about 10mm. so i shut off the cnc, let it go back to home by itself, tell it to go back to zero and then see that its off.

There does not seem to be a setting in the Carbide software that allows me to save the position (some other software does do this see the CNC nutz videos ( )

If you don’t change your work zero coordinates, they will not change. If you zero, home, go back to zero and you’re off by 10mm, you have a mechanical problem.
Home (machine 0,0,0) is the reference for all other points. Work zero is stored as an offset from home.
Can you send $# to your controller? This will show you your current work coordinate offsets.

1 Like

If you’re off after a rehome, then something entirely different is wrong. The part zero is stored basically relative to the home position, which is re-found when you home. If it’s off after rehoming, it’s more likely that it you had a skip issue -before- you set it.

1 Like

I would guess this is the indication of a problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.