First Power Up Error

Powered up my Shapeoko3 (Standard) #7568, verified in Carbide Motion that it was Ver 4, (read that back in April Shapeoko’s were shipped with GRBL v1.1 onboard) continued to JOG, Hit the homing tab/button, and Z drove the bit into the ground! Hammered it about 5-10 times, and came up with this error:

Your assistance as to what may have occurred & potential remidies is greatly appreciated.


What about taking a multi meter and setting it to continuity mode and manually testing the limit switch to ensure its not defective?

Or verifying the correct wiring and connection of the switch.

If you jog the Z axis manually (using small steps) does it move in the right direction? If it’s moving down when it should move up, check out this thread:

1 Like

I’m not too sure, since I thought I was heading to the manual JOG screen when this happened.

I have yet to see the manual Jog screen. I was at the Jog Tab, next button was home, and this is where the Bit sits as I type.

I am leaning towards reversed wiring somewhere.

I am sure it is Pilot Error! My Z wire is Brown & Y is Red. I’ll just power down and switch them around and report back to the Forum.

Just an update… Limit SW’s have been switched to correct positions (You know… A Guy thing)…

But while fixing that issue, I moved my gantry to the back and heard a weird noise. slowly over and over I moved the gantry back and forth by 1cm. Then I noticed the unit is out of square! And to think that when I assembled it, I used my Quick Grips just like the YouTube video I watched.

So out comes the rubber mallet to see if I can persuade it to square. But I think I better search for the area I think @wmoy shared on if your unit is out of square before I start slamming away!

No I’m in trouble!

When we assembled 7568, the first thing we noticed was the back waste board screws (2 if I’m not mistaken), did not line up. Removed the rest and started off with the stubborn ones. We were able to get them in, and worked the rest in reverse.

Now, I loosened my Y rails, and re-clamped them and worked the star pattern to secure them back tight. The Front Right was tight to the metal. Same with the Rear Left, when the gantry is moved to the rear.

Took off my Front Right clamp, and it was true to the metal. Proceeded with the Front Left clamp, and it sprung back to 0.1275" (1/8"). Same measurement from the front as well (0.127").

Better than that, with the wires switched Brown to Y, Red to Z, return to Jog, and once again it took a nose dive right back into the spoil board!

OMG! Wife is NOT going to be impressed with where this is heading. Time to see just what @reidfo has to share! Fingers crossed…

First off, how do you verify what GRBL you are running on your Shapeoko?

Then what the heck is $3=6 or $3=0???

Sure is beyond Greek to me!

Thanks all for your assistance. I think I best just walk away for now and collect my thoughts on this.

Not sure I can offer much help unfortunately since I’m pretty new to the Shapeoko and haven’t experienced this particular problem. Maybe @WillAdams can chime in with some advice? Look on the Wiki and closely at the assembly instructions to see the control board connectors and where exactly the X, Y1, Y2, and Z connectors go. Mine were labeled both on the board and on the connectors themselves. There should be a small catch on one side of the connector so you know which way is up when you attach it. @wmoy has probably the best instructions I’ve seen on squaring and leveling the machine. What surface do you have your Shapeoko sitting on? Is it flat and level?

The bit drove into the table when it tried to home? That means your Z servo is wired backwards. It should have moved up only.

can you send us a pic of the Z with out the router in? i may know whats going on if its crashing into the table while trying to home

Easiest way to verify which Grbl you’re using is to install and connect with Carbide Motion 4 — it’ll give an error if Grbl 0.9 is installed, and connect to 1.1

$3 is Grbl’s “dir port invert mask” per dir port invert mask:00000110) — it’s a set of binary digits which will reverse one or more axes depending on how they’re set — see the wiki for details.

If your machine moves down when it begins homing there are 4 possible causes:

If your plate is properly installed and the wiring seems okay and you’ve updated the defaults, check things by trying to manually move the axis — see:

If the Z-axis goes down despite receiving a command which should move it up, then let us know at and we’ll get it sorted out.


OK, so for now I had to walk away from this build a take a breather. No biggie, from time to time we all need to stand back and reflect.

OK… so I took some more photos, which I’ll post to assist.

Back Right of unit.

Front Left of Unit

Rather than made Swiss Cheese, I decided to pull the gantry forward.

Lots of these today!

Control Box wiring, once I realized I had to jump into here to match the SW’s.

(Please note that ZYX for the Limit SW were marked prior to this, so now it reads as YZX (=ZYX).

Once that was all verified, I powered 7568 back up, and went to jog. This time Zed finally travelled upwards, X moved to the Right! (we are on a roll here Baby!), but Y motored forward and did not want to time out (5-10 hits before RED Flag was shown on the screen for the earlier errors).

What I can tell you is /$3=6 did not seem to work (Not too sure if I tried this out AFTER I switched Z&Y around?). /$3=0 Lifted Z, and traveled to the Right! But failed at brining the gantry to the rear of the ship.

I will now take a further break, take a couple headache pills and return to read what others chimed in to share with me!

Thanks guys!

@reidfo, yes the table is flat. My shed dips to the back by a few degrees, but the centre table (where the Shapeoko sits on is flat!. I have also ran my 4’ level to verify for warping, but for a 3/4 Plywood bench. It is a solid base to work with. Thanks for these thoughts, as we all can see tiny things were overlooked, and look where this has lead me too…

I agree, seemed to have rectified this issue.

will do… sec @orlrobinson.

Thanks Mark!..

1 Like

Either Google or SaskTel has gone to sleep on me. Took 2 pics, sent twice, and still has not arrived in my inbox!

Will jump on them when they arrive to my inbox.

Thanks Mark!

1 Like

To reverse the Y-axis you can power down and swap the two Y-axis connectors at the control board.

1 Like

Sounds like you are making good progress, Michael. It’s a steep learning curve for many of us, including me. I’m struggling with some alignment issues as well (Z axis depth mainly), but just got my new Beaver HDZ Z axis, so will install that before troubleshooting any further.

1 Like