First real issue with my S3XXL

I am a new S3XXL owner. I bet this is an operator error!! All has been great until an issue. I made a 30 second video below. It occurs at the 0:17 mark.

  1. I have tried this 4 times (4 different wood blocks) and it repeats each time. On the end of the 8th pass (of 10) something happens on the z axis moving up. It binds (loses steps?). Like something is jammed in the V Wheel. I hit the kill switch because it tries to route too deep on the next pass. The Z plate is then “sticky” up/down. But nothing is in the wheel system or the rails. When I turn the S3XXL board back on and re-Home it, the Z plate moves up/down very smoothly the full range.

  2. I ran the entire gCode with no bit and no material. It seemed to run fine the full program.

  3. I took the Z plate off after the first fail. I cleaned everything real good and reinstalled it. But the fail happened exactly the same. I had a new bit and even changed the spindle (router) on try 3 and 4.

I do not have enough experience to do much more troubleshooting. Thanks for looking at this.

1 Like

Hmmm…something in the gcode that was generated maybe? Does it do the same on “every” file or just this one?

1 Like

Please post your G-Code file and/or send you Vectric file in to support@carbide3d.com — it seems to be doing a lift for some reason — if it’s in the file it could be caused by setting a datum.

Which post-processor are you using?

2 Likes

Here is the gCode file. I am using the Shapeoko (inch)(*.gcode) PP in Vectric Aspire. I did update to v9.514 yesterday. Maybe just a coincidence. I think it occurs roughly around line 20,000. Give or take 1K.

01 Top_Pocket Base 0.25EM.nc (467.7 KB)

1 Like

I don’t see the lift in the preview:

but here it is in the code:

G1X2.1372Y3.8054
G0Z0.2000

but that appears in a lot of places and what follows isn’t unusual.

G0X2.4773Y2.4458
G1Z-0.9200F30.0
G1X2.5000Y2.4215Z-0.9219
G1X2.5227Y2.4458Z-0.9238

G1X2.5000Y2.4215Z-1.0267
G1X2.4773Y2.4458Z-1.0286
G1X2.5227Y2.4458Z-1.0312
G1X2.5000Y2.4215Z-1.0331
G1X2.4773Y2.4458Z-1.0350
G1X2.5000Y2.4215F100.0
G1X2.5227Y2.4458
G1X2.4773Y2.4458
G1X2.3605Y2.5021
G1X2.3806Y2.4784

I suspect the problem is a combination of mechanical — the belt is warmed up and the retract happens against an edge and it doesn’t lift as much as it thought it had.

Please try replacing that line with:

G1Z0.2000

throughout, and also check the Z-axis belt tension — may want to temporarily remove one Z-axis spring.

1 Like

My first guess on seeing the video and reading this comment is EMI. The power cord for the router produces a lot of electrical noise. Get it out of the drag chain and run to the right of the machine.

2 Likes

WOW. That is super impressive to me. What did you use to analyze this? I used to do a lot of programming and learning gCode is on my list. But receiving my new machine in January, I wanted to get “cutting”. This forum is awesome. I am amazed how people will help each other. I can’t wait to have enough knowledge to be a “helper” as well.

1 Like

You were spot on. I used a different bit, slowed the feed rate and hand vacuumed. It did not bind on that wall. I did not change the programming at all. It was definitely a mech issue.

2 Likes

Hi, Seems like you solved already, but had a very similar issue. For me it was the Z belt had got loose over time. or maybe just not tight enough at the start. When it tries to move down in Z on some materials it would skip a tooth on the belt and then misjudge the depth and cut too deep the next round.

Its relatively quick to pull the front off and tighten up the belt to make sure this is not happening. It may mean you can run at a more reasonable rate.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.