Font Birds of Paradise wont show up in CC

I had seen a project by Gary Mitchel that I liked the font. Gary was gracious enough to give me a link to the font. I downloaded and installed but it does not show up on CC. It is most likely a permission problem but I went into Control Panel, Appearance and Fonts. I looked at the properties. I am the only user on my computer and have administrative privilege. The properties are all checked for use but are grayed out and not selectable. The font states it is for personal use only. I looked at other fonts to compare and none of them are grayed out. There was no option for “Install for all Users” in the install button (right click).

Does anyone have any suggestions to get this font to show up in CC.

I use LibreOffice for my work processor and the font shows up there.

I am running Windows 10 (Update 1909) and all other Windows updates installed as of last night. The Laptop is an HP. I have installed other fonts and they work ok.

This comes up with Win 10. Here’s the fix. I had to do it as well for Inkscape when I finally upgraded to a Win10 machine.

Thanks to MadHatter for replying but that did not work. I deleted the font and re-installed with the option for all users. It did not show up in CC. I went in to the fonts folder and looked at properties and then into the security and “Allowed” for all of the 5 entities in that folder. Still no luck. The font does show up in some applications but not CC. In the referenced post you gave I had the same problem with the fonts that do show up not being in alphabetical order and searched the list multiple times.

Any other suggestions.

you can also directly install the font into CC by opening the data directory
(see the About option under help) and copy the ttf into the respective folder there

1 Like

Thanks I will try that.

Tried that and still no luck. In the Carbide3d Data directory fonts folder I did a properties and the security section the 3 users cannot be changed to “Allow”. The check boxes are grayed out.

Please send a link to the font and its license to and we’ll do our best to look into this.

However, note that Carbide Create (and other QT apps) seem to have a limit on how many fonts they can access — Windows seems to allow for more, and the QT list seems to be first-installed, first-listed, so if you have a lot of fonts, uninstalling any which you don’t need may allow this to show.


Thanks I sent to support.

To close the loop here, the font in question is a free version which has had some changes done to encourage folks to purchase a license — since the QT libraries which we use expect a correct font with a space character not having numbers, and the other technical errors in the font unsurprisingly keep it from working.

I would suggest getting fonts from a source which is not intentionally crippling them such as

1 Like


Thanks for your attention. I had seen the font on someones project and they replied. I did see that it was a “Limited” or “For Personal Use” but I am sure I can find something else to use. The person that used the font is using Vetric Pro and it showed up fine in that application. The mysteries of Windows keeps getting spookier and spookier.

Thank you for working this problem.

This topic was automatically closed after 30 days. New replies are no longer allowed.