For Testing the Home Switches on S3 XXL

I just set up the new S3 xxl and all wires through the various tunnels (the hardest thing of the assembly by far) and think I have the correct wiring but the motors do not stop the gantry when playing XYZ in the JOG feature of the Carbide Motion.

Is there any simple test to make sure those are connected correctly ? If I play XYZ in CM JOG page and touch the sensores at the same time, will everything explode?

Please advise thank you.

Although it’s after the fact, did you realize you can take the drag chain covers off so you can just lay the wires in there rather than fishing them thru? This is the only way to do it for the gantry bundle since there are so many wires.

Anyway, I just put mine together too and at first the limit switches did not work. First off, in Carbide Motion, go to the Settings screen and you must enable the Homing feature…turn the false to TRUE. Then when you go to the JOG screen it will want to run through a Homing Cycle, this may or may not work the first couple of times.

Still the switches may not work right away. I found I had to push them several times to sort of “loosen them up” or something, not sure but I saw some other posts about the internal contacts not working until you work the switches a few times. Try that and see what happens.

Thanks for those great tips. I’ll give it a try!
Yes I did realizes you could take the chain cover clips off after I sweated running all the cables in haha thanks

Ok so I just changed the Setting value to True for the Shapeoko has Homing then clicked on Job and was asked to Click to begin homing witch I did and got an error message : GRBL Error: Setting Disabled

I trying it already 5 times and the same thing keeps happening. What did you do next?

Try rebooting the computer and turn off the Shapeoko and then back on to make sure the setting are reset. Then when you reboot verify the wrote to the eeprom and are fixed. Then try to home again

Heres the link to enable homing in GRBL: