Freezes on homing

I can’t seem to get my nomad to home (or do anything) anymore - I can connect to the machine, but when I click “Click to begin homing”, the head doesn’t move.

I was running a job without incident but noticed that my stock was slipping a little bit, so I cancelled the job and retaped the stock. When I tried to rezero the cutter, I started having this problem.

power is on (I can hear fan spinning), e-stop is out, and I have cycled power to both nomad and computer (and tried both mac and pc). When power is off, all three axes can move freely.

Anyone have any advice? Maybe there’s a short or something and the e-stop is permanently closed? I’m happy to take my machine apart and start tinkering, but only if it seems necessary…


Hi Ben,

Sometimes what happens when you interrupt things with the machine is that the connection with GRBL gets out of whack, and you need to close and re-start the connection by closing and reopening/restarting Carbide Motion.

Also, if you used the E-stop, you’ll need to twist & pull it to get it to release and re-enable the machine. You may still have the E-stop in without realizing it :wink:


Thanks @UnionNine - like I said I’ve restarted both the machine and my computer several times, and the e-stop is most certainly out. Cutter still won’t move and I’m stuck on the “Homing Machine” screen in carbide motion


Whoops, that’s what I get for doing too many things too quickly, I missed the “e-stop is out” comment!

Let’s get a few other things sorted out:

I know it sounds trivial, but (with the machine off) have you tried manually moving the head of the nomad out into the center of the gantry, moving the table toward the center of it’s movement area, and moving the z-axis toward the middle of it’s movement range, all to make sure it’s not starting on the end-of-travel sensors?

The G-code job that you last sent—what software did you post it from? (And could you include that in an email to us that I mention below?)

What version of Carbide Motion are you using?

Lastly, can you fire up carbide motion, and before you push any thing else, hit the “L” key to open the log and then try to connect to the machine? After you’ve done that the machine should be ready to home and then measure the cutter, etc…

If you could copy the log from that initial handshake of “connect to machine” until it freezes you out, and paste it to a text file that’d be helpful, and email it to “support at carbide3d dot com” with the correct formatting of course. From there that’ll open a ticket and we can take a look into it more closely.

Thanks, I just sent an email with all that information.

For any lurkers out there - my z-axis motor was unplugged! When the nomad homes, it starts with the z-axis, and the spindle wasn’t moving in the z direction, hence the freezing.

You can try to reach around and plug the cable back in if you have tiny fingers, otherwise you can take the top panel out by removing the screws on the back panel and loosening the screws on the left side panel until the top can slide out. A wise man would tape or zip tie the motor connector in place.

Thanks Jorge for your help on this!

On my Nomad the motor connectors have nice large locking lugs

I’ve unplugged and replugged all the motors several times and can attest to the retention power of the lugs (and the difficulty of unplugging them…) Perhaps your connector wasn’t plugged in fully to begin with. In that state it would be easy to slip off.