Fusion 360 Odd Behavior

I attempted to cut my first job this afternoon after upgrading to grbl 1.1f. If I post process my job out of Fusion 360 (or Autodesk HSM Ultimate) and then attempt to run it in grbl-panel, my z moves upward until it hits my limit switch thus alarming out. Perhaps it’s something simple that I’m not noticing but I cannot seem to work around it. Alternatively, I tried VCarve Desktop and it works just fine.

When I had grbl 0.9, the first thing that my machine would do is home and then rapid to the first cut. Does anyone have any advice?

Shapeoko 3
grbl 1.1f
grbl-panel 1.0.9.15
latest carbide 3d post processor (44 days old)

Files.zip (3.9 KB)

Configure Carbide Motion for homing?

CM4 requires that homing be enabled, and that one have homing switches

I have homing switches and it is enabled.

Okay, I think I found the problem.

I modeled the same part in Inventor 2018 (with HSM Ultimate) and Vcarve Desktop 8.5. Just a simple 2" x 2" x .5" thick block with a .75" diameter counterbore at .125" deep. I exported the gcode in Inventor and Vcarve. In Inventor I used the latest Carbide 3D post-processor found on the Autodesk site. In Vcarve I used the “Shapeoko” post processore that I found in the Vcarve forums. I opened both gcode files in notepad and compared them. I noticed that the Inventor/HSM version had a “G28 G91 Z0” in the header section. Vcarve did not. So on the command line in grbl-panel, I entered “G28 G91 Z0” and sure enough it send my z axis up until it hits the limit switch and errors/alarms out.

Now, if I use the grbl post-processor instead of the Carbide 3D one, I notice that I have a G28 option that I can turn off. So, I turned that switch off and exported my code. When I try to run that in grbl-panel, my Shapeoko works as it should.

So going forward I’m still a little confused. I always had that “G28 G91 Z0” code in the past when I was using grbl 0.9 and it worked flawlessly. Now that I have grbl 1.1, not so well.

Here are the starts of all three files that I’ve tried:

Inventor/HSM gcode (Carbide 3D post) partial…
%
(Pocket_hsm)
(T201 D=0.25 CR=0 - ZMIN=-0.125 - flat end mill)
G90
G17
G20
G28 G91 Z0
G90

(2D Pocket2)
M9
T201 M6
S5000 M3
G54
M9
G0 X0.9286 Y1.1135
Z0.6
Z0.2
G1 Z0.1 F40
G3 X0.8589 Y0.8865 Z0.087 I-0.0349 J-0.1135
X0.9286 Y1.1135 Z0.0739 I0.0349 J0.1135
X0.8589 Y0.8865 Z0.0609 I-0.0349 J-0.1135
X0.9286 Y1.1135 Z0.0479 I0.0349 J0.1135
X0.8589 Y0.8865 Z0.0349 I-0.0349 J-0.1135

Vcarve gcode (Shapeoko post) partial…
T1
G17
G20
G0Z0.3750
G0X0.0000Y0.0000S12000M3
G0X1.0000Y1.0500Z0.2500
G1Z-0.0250F30.0
G1X0.9934Y1.0496F100.0
G1X0.9867Y1.0482
G1X0.9799Y1.0458
G1X0.9734Y1.0424

Inventor/HSM gcode (grbl post) partial…
%
(Pocket_hsm_grbl_g28no)
(T201 D=0.25 CR=0 - ZMIN=-0.125 - flat end mill)
G90 G94
G17
G20

(2D Pocket2)
M9
T201 M6
S5000 M3
G54
M9
G0 X0.9286 Y1.1135
Z0.6
Z0.2
G1 Z0.1 F40
G3 X0.8589 Y0.8865 Z0.087 I-0.0349 J-0.1135
X0.9286 Y1.1135 Z0.0739 I0.0349 J0.1135
X0.8589 Y0.8865 Z0.0609 I-0.0349 J-0.1135
X0.9286 Y1.1135 Z0.0479 I0.0349 J0.1135
X0.8589 Y0.8865 Z0.0349 I-0.0349 J-0.1135

Your G28 reset when you updated the firmware. Try running a G28.1 to set your G28 location at a position you want. Jog to where you want G28 to be and send G28.1
You can send a $# to read the current values. If the G28 Z value is 0, it’s on your limit switch.

1 Like

Yes, that was it! I now remember doing that 2 years ago when I was setting up my machine. I had forgotten about it. I set G28.1 at the 5mm offset after the homing cycle. Everything works as it should again.

Thank-you. I appreciate it.

1 Like

No problem. I usually disable, or manually remove, g28 anyway because I use my G28 for a tool change location which is usually not near my workpiece zero.