Fusion 360 - When importing ".nc" file ERROR (3): Error in line 19: Bad Arc Format, No I/K

Not sure what this means but I was ready to do my first test job of a production piece using Fusion 360. I made everything using Fusion 360 and mimicked as best I could the settings from Carbide3D for the particular tool/toolpaths and when I loaded the file into Carbide Motion to start it up this is what I got:

Yes, I unchecked useG28 but I am on a Shapeoko XXL with Homing switches and not sure if that would be an issue

Ok nevermind I fixed it. Should I delete this post?

Basically instead of using grbl.cps - generic grbl for Post I switched it to carbide3d.cps - Generic Carbide 3D (Grbl) and it imported just fine.


No need to delete, I think it’s a good thing to have the problem described along w/ a tested solution.


@Savant_PCs: I found the problem with a bunch of the fusion360 grbl-related posts. The only one that seems to work with CM 4 and GRBL 1.1 is the current “carbide3d.cps” autodesk post. The grbl.cps post has the I,J,K problem, as does the stroom post.

So I fixed one. This is the stroom post with some adjustments by me to also make the Dewalt vs Makita speed dial selection adjustable (defaults to Dewalt 611). He deserves all the credit on this one, and I really should submit back my fixes, but haven’t yet. This seems to be working ok for me. I might be able to help you out if it doesn’t work for you. (I’ve been crashing Fusion360 with 3d ramps today…don’t think it’s related though)

If you’re feeling really brave, here it is:
C3D-MikeP-Dewalt.cps.zip (5.5 KB)


I ran into a grbl error today. The Fusion 360 forums said to force the thing into metric before doing the post. That cleared up my error (it was arc-related, also).

The stroom one will warn about the metric/inch conflict.

1 Like