Goes home instead of running

(Jared Hooper) #1

I’ve never had this issue before and I’m a bit stumped. I’ve created a toolpath file with CC3 for my S03 to engrave into a small acrylic piece for an edgelit nitelite. I homed the machine as usual and jogged the machine to the center of the workpiece, zeroed the x, y and z, and as usual zeroed all. Loaded the file and hit Run. The z retracted the specified height but instead of being asked to insert the right bit and continue it immediately, and rather quickly, headed for the home position where CM then asked to insert the proper tool and continue. Clicking continue just caused an odd noise and shuddering so I shut it off. Tried this a few times with the same result.
What it seems like is the zeroing I did didn’t take somehow, but that’s just a suspicion.
I’m no gcode expert but it seems to look OK … I’m including a snippet of the top dozen lines of the code below. Anyone got any idea what might be happening here?

M6 T250
M3 S2400

(Julien Heyman) #2

Happened to me once, and retrospectively I think I mis-clicked on the zero all button while zeroing. When I re-zeroed and re-launched the same job immediately after, it worked fine. I have now taken the habit of actually checking that all coords are actually reset to 0/0/0 after clicking, instead of doing it absentmindedly as I did before.

(Jared Hooper) #3

Well, this morning I tried again with the file I want to do and with two other files I had successfully run before. I did the homing, jogged to where I want the work to start, zeroed the x y z and set those.
In the jog screen after moving the tool where I want to start and clicking the set zero the next screen comes up where you can rapid position. On that screen I also click Zero all then Done, this has always worked before.
I then loaded the file, clicked Run and off the machine goes back to home and behaves like I first mentioned so something is still wrong. It just doesn’t to be recognizing the work piece zeroes I set in CM.
One thing that happened when I first started on this project is when I did the first homing I didn’t notice that one of the cables had gotten in the way of the y axis and didn’t allow that homing switch to make contact so it didn’t home properly. I shut everything off and repositioned that cable then started up again and all seemed fine until I hit Run and now keep getting what’s described above.
Still can’t figure out what’s going wrong or what to attempt next.

(William Adams) #4

Please verify things step-by-step:

  • machine in good shape w/ everything properly plugged in and homing switches properly working to light up the matching lights?
  • homed successfully?
  • zero set properly?
  • does the machine behavior match what is set in the G-Code file?

Check in the log to see if anything unusual is going on? Unsupported G-Codes used to make the machine behave oddly, drifting into the back corner.

If nothing obvious turns up, please send:

  • source .c2d file
  • generated G-Code file
  • specifics of our setup (CC and CM versions, computer OS, &c.)
  • detailed recounting of:
    • what you did
    • what you expected
    • what actually happened

to support@carbide3d.com and we’ll try to help you sort this out.

(Jared Hooper) #5

Thanks Will, I’ll check everything out a lot closer and see what I find. I’ll report back later and send all the details to support if I can’t resolve the issue.

(Jared Hooper) #6

Double checked everything yesterday and all the connections and limit switches are fine. I uninstalled Carbide Motion and reinstalled it, swapped the usb cable and tried a few more files that worked before but the problem is the same. Looked at the log which seems fine but I’ll admit most of it is like a foreign language to me. It seems to be homing properly and also seems to be allowing me to set the zeroes but trying to Run the file just sends the machine to the home position. When I try the rapid positioning instead of going to the zeroes I set it either remains in the home position or goes there if I’ve jogged it away from there. Leaves me thinking something has happened with the board. I sent support all the details and await their response.

(Jared Hooper) #7

Still patiently waiting.

(Andy) #8

If you want post the first 20-30 lines of gcode here and we can help while you wait.

(Jared Hooper) #9


Support did get in touch with me this morning and I’ve sent them a bit more info (log details from the $$ command etc. They said my gcode file looked OK.

Anyway here’s a snip of that gcode …

M6 T250
M3 S2400

I’m no expert with gcode but I don’t see any problem there. It seems be be directing the machine from the work zeroes I set but the machine itself just doesn’t seem to be accepting the work piece zeroes, on Run it just heads for the home position and stops there (without backing off the 5mm) so it looks like it’s “thinking” work zero is somewhere other than where I set it. I can’t do anything further from there. I can’t see it being a CM software glitch because it still happens after a re-install (version 366).

(Andy) #10

Yeah, I may not be too much help since I updated my Shapeoko to Grbl 1.1 so I have to use CM 4. Have you tried any other programs to send the Gcode such as Universal Gcode sender? You could try homing it in a different program, jogging it and setting 0 for X, Y, Z, moving it to a different location, and then manually sending it G21, followed by G90, and G0X0.000Y0.000Z5.000 and see where it goes.

(Jared Hooper) #11

Before using CM on the project I started with PicSender (which i use for the laser I have and often with the SO3. It’s a good sender. It wouldn’t send the file at all just returned an error, something about the G20 and G90/G91 which I didn’t quite understand. So I tried it with CM and the problem with it returning homeward began. That might suggest something wrong with the gcode because Pic sender has always worked with the cnc before.

I’ll try to do some manual gcode sending tomorrow if I don’t get more ideas or solutions from support.

(Kyle) #12

I received my SO3 a couple weeks ago but have had little time so far to actually use it. After I assembled it, I did run one successful job on it with no troubles! I had some free time today to run another job I have been working up and I experienced this exact same issue. My first thought was that I probably fat fingered something while using Carbide Create so I decided to go back and run the first job since i knew it worked. To my surprise, that job behaved the exact same way as the first and as Jared described above. I continued to mess around with trying to re-home it and to re-zero the machine. No matter what I tried, I kept getting the same result. I started combing through the forums and I saw a lot of people use UGS as a sender so I gave it a try. UGS ran the GCode fine but I was not too happy with the interface and found it to glitch out more than I liked so I did not stick with it. I would really like to use CM to operate my SO3. Any help would be appreciated. Thanks in advance!

(Jared Hooper) #13

My issue turned out to be a problem with the PCB (which I suspect was caused by a power surge when a transformer blew in our neighbourhood). I got a new PCB and swapped it out and my machine has been running fine since. Hope you get you problem sorted out.