GRBL 1.1 and Carbide Motion 4

If its not the post, I would also try deleting 4.0.407, and go back to 4.0.406 to see if the problem still exists.

I am having issues installing 1.1 on my 883 Pro. After detecting the machine and confirming that GRBL 0.9 is installed, the program complains that the z-axis limit switch is not pressed down (even though I am holding it down) and refuses to proceed. To humor myself, I tried holding down the y and tool length sensor limit switches (just in case), but no go.

Anyone experiences this? I emailed beta (twice) and carbide support after: for some reason no-one is replying…

1 Like


Where on this control board would you wire the PWN and Ground wires too. It is not as straight forward as the previous control board or I am simply missing it with my old eyes.

Suggest providing you board version # in a query to

Thanks for the advice. I did just what you suggested

Same spot as the white board, there are 6 pads on the right side of the board below the cap. Mine is a 2.3 or 2.4 board (can’t remember) Yours is marked 2.3 (lower left corner). On my board, it matches the white board below. I’ve got a year old nomad pro, and a shapeoko 3 xl, and that set of pads seems to be the same on both, and matches this white board, at least in this spot. On the nomad, the spindle controller plugs in there. There’s a handy PWM and GND there. (Keep in mind, I don’t work for Carbide3D, they’re the ultimate authority here)

1 Like

Turns out with this post for v-carve (that i had modified to include tool data, time, file name, ect…) that i have to start at the work zero. With post from fusion i always just started from wherever it was.
So this was in no way a CM problem.

1 Like

Hi All
updated gbrl on the shapeoko 3 XL and motion 4 on the pc ( win 7 ) and my Mac book pro ( Sierra OS X )

Carbide motion 4 loads
I click on settings and set the dropdown to shapeoko XL
there is no homing button available on the pc or the Mac.

if I click on jog, the machine goes into homing mode , sends the z axis down 1cm and requests me to close the door

very confusing
the machine is unusable

anyone had similar problems

thanks in advance

There is no longer a homing button, correct.

I had a similar issue, and needed to reselect my machine to correct the wrong way Z.

I hope you sent an email too.

Yep sent one of those,
but being the weekend I don’t expect a reply until Monday
how did you resolve your issues and did you have the door open test come up

1 Like

sorry door open text

No Door text.

I test boards for Carbie3D so I have upgraded 3 times now, so I’m a little more familiar with the process (and errors) them most. As soon as I saw the Z move down (rather than up) I hit my estop, reconnected and went into settings, clicked on the log window (saw that Shapeoko 3 was selected), then I opened the MDI page, typed $$ and looked at the settings in the log window (mainly I was looking for $130-132 (machine size) and noticed that the machine TYPE didn’t take.

Went back into settings, reselected Shapeoko 3, and clicked Send. Typed $$ back at the MDI page, checked the setting, and saw that the setting were NOW correct.

THEN I clicked home machine, and it all works great, and have used the machine nearly everyday since then (3/22).

The signs you are posting clearly tell me that the wrong machine is inside GRBL, and it is easy to change. Now why didn’t it take the first time? I don’t know.

1 Like

Thanks Richard
I will have a bash at that in the morning

interesting stuff.

The plot thickens

tried all of above and the motion 4 software is still saying door open and the z axis moved down

I turned the machine off moved the router manually to the centre and loaded a simple file to cut a circle

with the router turned off I switched on the machine ,run the program and let the machine go through its paces, after it finished it would let me go into jog mode .

No matter what buttons you click nothing happens apart from done

very frustrating

Please send an e-mail to w/ the specifics.

To go back 0.9 GRBL 1.1 and Carbide Motion 4

Have you checked the settings to see if they are correct for your machine (e.g.$$)?

done that
going back to ver 9


Thanks will
I have a shapako 3 XL what chip is on the board
ver 2.3 pcb green colour.
dont wanna blow anything up

and I will be sending a detailed e.mail for the nice chaps at shapoko

Hi Chaps
back on ver 9 now
all working now apart from the limit switches
I have worked through will’s detailed plans and all good apart from
machine in the middle of the bed and when you try to home
hit limit switch comes up

the quest goes on

Make sure you type $22=1 at the MDI line to enable homing in GRBL.