GRBL 1.1 and Carbide Motion 4

@Wannabe_Maker and @sagertat - I noticed this once also.

If either of you can reproduce - please send an email to

Just uploaded build 404 (links above).


  • Jogging problems fixed (occasional runaway)
  • Incremental jogging cannot be interrupted now
  • Slow jog mode removed
  • Changed logic for Pause/Stop buttons to try and fix cases where they were disabled incorrectly.

If any problems come up, email us at

1 Like

Just uploaded build 405 to file the “Copy GCode” button.

Based on the feedback we’re seeing, I think we feel comfortable with more people trying this out. We’ll put it on the blog later today.


I tell you what 1mm increments is heaven! Jogging has never been so good!


Just uploaded build 406 to fix the problem where a file would not be updated if the gcode changed but the filename didn’t.

1 Like

Hi @robgrz,

Where is your fork of grbl that you’re using to build these firmware updates from?


answered here: GRBL 1.1 changes from stock?

Please don’t do this.

Has anyone here solved an issue with carbide motion 406 silently failing to launch under windows? Does the software generate a log file anywhere when it’s launched?

I am running the sparkfun version and had to use xloader to update the grbl firmware but after that everything seems to be working fine. Will add more information on how a couple projects I will be running go over the weekend.

1 Like

I just updated to 1.1 and C4 (406). new GUI looks good, but I am still seeing this problem where the newly loaded file does not update. I tried loading a bunch of different files just to see if the boundary extents or file name would update, and after loading several different files it changed to the second file I tried from the first, but definitely did not update in real time.

a request. when using the MDI function it would be nice if you could hit enter to send the command, rather than having to mouse over to send. Also, it would be very nice if it showed the history of commands sent. just a 10-20 line scrolling log so that you get a visual confirmation that your command sent and what the last one was.


I’m still seeing it too as of 4.06 update. Windows 10. Loading and reloading several times does finally show correct file, but this could be disastrous if I were to run the wrong file by accident.

Also have noticed that I’m having issues with jogging via keyboard shortcuts, using mouse clicks works fine. X/Y work fine. Z does not work at all and jogging increments can no longer be set with Num lock + 1-5. Reported to Beta@carbide email, have not received response.(figure with new software release everyone is swamped). Mentioned in thread about jogging with wireless 10 key, but have not seen if anyone has the same issue(I could be doing something wrong?).



I have not seen this with 406 on Window’s 8.1, but I did see it with the earlier versions. Please go to the RUN screen after trying to load the file (just once), and I think you will see that the file is in deed loaded, but the FILE page just isn’t updating. Please let me know if this is what’s going on.



1 Like

I have an IOT remote switch set up for the router on my SO3XL. The Gcode for the tool change is before the M3 to turn on the spindle, but when running carbide motion, the tool change dialog comes up -after- the spindle has been turned on. Which is not so helpful. Gcode was generated from carbide create in this case. Spindle enable/disable works properly (ie. on when M3, off when M5)


M6 T12
M3 S7639

The remote control of CM is fantastic via the web browser! I use a Kangaroo PC at my SO3, and always run it headless. This is a lot nicer than needing to use VNC/RDP. This is an awesome feature.

I keep getting caught out by how the buttons work. The menu in the top right doesn’t seem to work if another screen is up. Example: enter Jog, then “rapid”, then click “jog” or “run” in the menu - nothing happens. You have to click done in the page, then the menu works. It’s totally unclear that the menu is disabled in these modals…you have to just know that you need to click the yellow “done” buttons to get things working.

@SWBennett Have you resolved your issue with the “door open” message?. I just upgraded to the new firmware and CM and are experiencing the same issues as you did. Sent a message to Carbide 3D already but was wondering if you already had their resolution to your problem. Could you share if you do, please?.

So I investigated further. (for ref running windows 7) It does as you suggested. When on the load page the file name does not refresh, but if you click over to the run tab it shows the latest loaded file. then when you click back to the load page it shows the new file as well. so i suppose the glitch is only in the instantaneous refresh of the load page.

1 Like

what is the appropriate place for feature requests? I imagine you don’t want the bug email filled with "i wish it had"s. I’ll assume this is the right place until I’m told otherwise.

So I wish the MDI screen had a stop and reset button. If you give it a command and fat finger a feed rate there is, as far as i can tell, no way to abort. For instance G01X100Y200F10. is going to take FOREVER to get there. but if there was a pause/cancel/reset back to idol button you could back out and resend with a reasonable feed rate.

On another note, I guess the memory banks have gotten a lot better? I powered off my machine for the night and when I turned it back on i was able to go to the “zero” that I was using yesterday. Pretty handy really. My machine is still prone to random disconnects as it is a V2.2 PCB. so a quick home and return to zero to pick up a program or do a tool change is pretty awesome.

Jorge spent some time skyping with me to figure it out.
There was an issue with a pullup on the version of the board I have. I will have to defer to Carbide support to work out if this is the right fix for you.
If I where you and needed to use the machine, I would revert to the older versions for now. There are instructions above.

1 Like

Thank you @SWBennett. I have already written them and are just waiting for their answer. I’m on a Mac and can’t figure out how to re-flash GRBL 0.9 again. Is it through Arduino?. The steps above say to use XLoader which seems to be a PC program. Am I missing something?.

To reflash on a Mac best to use the Arduino dev tools per

Thank you @WillAdams. Got 0.9 reflashed with HexUploader on my Mac and defaults were reset. Back to working order. Will wait until the official method for GRBL 1.1 for the Nomad Classic gets posted. Thank you all.