GRBL Error - Not USB, feeds/speeds? Spindle current? SOLVED

(Frank Wood) #1

Hi, I have run into a GRBL error issue. I created the gcode for Nomad from MeshCAM 7. The spindle shut down and the grbl error occurred at the same place in the gcode every single time. From previous posts this normally means that you have noise in the circuit that powers your Nomad and your USB signals to the machine become corrupted. However, I followed all of the suggestions and changed to cleaner circuits. Nothing worked, the error continued to occur in the same place. This happened when the mill was cutting out a bearing trace in 1/8" Aluminum.

It appeared to me that the error cropped up (and the machine stopped) when the spindle was stressed. So I cut the feed rate to 50% right at the point where the bearing trace was being cut out. When I ran the job it cut out the bearing trace and continued until the next more complicated part of the gcode.

I am thinking that somehow the amperage draw on the spindle motor is triggering the grbl error. It looks to me that I need to feed the spindle motor more power or change the feeds/speeds when I do complicated cutting. Any ideas?

… PROBLEM SOLVED
Because I am a newbie to MeshCAM 7 and Nomad, I used the default feeds and speeds for Aluminum in MeshCAM (feed 9.8, plunge 1.2, 10,000 rpm and step-down 0.038). However I found this document Nomad883_feeds_.125
I was cutting through 1/8" aluminum in three passes. When I changed to the smaller step-down listed in this document my cuttings were not that much smaller and the job ran all the way through.

Kudos to the Carbide 3d folks that have responded to my newbie issues, even over the weekend.

1 Like

(Neil Ferreri) #2

What error? (More characters)

0 Likes

(William Adams (Carbide 3D)) #3

Please contact us about this at support@carbide3d.com and we’ll do our best to work this out with you.

0 Likes

(Frank Wood) #4

Thanks for responding. I had been getting the same error; “Serial Port Resource Error”. The error number seems to cycle: 1, 3, 4… It runs great cutting out holes, but when I am cutting out something complex if I don’t chop the feed rate (given the standard feeds/speeds for aluminum in MeshCAM 7), I throw the error.

0 Likes

(Frank Wood) #5

Thanks, I will contact support.

0 Likes

(Neil Ferreri) #6

That’s not an actual Grbl error, I wonder why CM reports it that way. It really sounds like EMI. Have you tried another sender or even another computer?

0 Likes

(Vince) #7

In my experience even a near stall will trigger errors.

Mind telling us the feeds/speeds you were running? A single flute endmill might be a good change to reduce load per revolution.

1 Like

(Frank Wood) #8

Nomad is new to me so I used the standard feeds/speeds that were loaded into the MeshCAM 7 software;
9.8,in/min feed rate, 1.2 in/min plunge rate and spindle speed 10,000 rpm. Step down is .0038 in. This is the standard for aluminum built in to the MeshCAM 7 software. These settings are similar to what I use with my X-Carve. I am beginning to suspect that the spindle is not moving at 10,000 rpm because the spindle is really quiet and when I gave it a gcode command to turn at 10,000 it was much louder. Not very accurate, but it must be a relatively minor problem.

1 Like

(Peter H) #9

Please try without cutter (if possible). In my case this worked without errors and I could figure out that the EMI of the spindle was the problem.
See: https://community.carbide3d.com/t/solved-machine-stops-cutter-not-responding/15260

1 Like

(Frank Wood) #10

Thanks Peter, it is starting to look like an issue of feeds/speeds.

0 Likes