GRBL might be freezing?

I am getting a severe rash of these now on every cutting job that has some time in it. Very frustrating to restart multiple times! I have to think my GRBL board has become defective in someway. Last job I did with VERY easycut depths and speeds. Should have been minimal effort on the router. Dewalt router set down to 4.5 speed.

I was milling Maple taking 0.05 depth cuts at 40 in/min, 15 down.

I tried to skim the thread, sorry if any or all of this has already been suggested. The magic cocktail for me (so far, knock on wood) includes:

  1. Router and dust collector power cords routed off the opposite side from the C3D board into a different circuit

  2. Anti-static dust collector hoses

  3. Connection from computer to Shapeoko as follows:

Computer ->
Powered USB Hub ->
Industrial USB Isolator from Amazon ->
Very short USB cable ->
C3D board

  1. Sacrifice a rubber chicken to Kek.

(Just kidding about that last one).

Ignore this if I’m just repeating things already suggested.


This happened to me last weekend and running the program at 120% seemed to get me through the job.

Just got the board in the mail today. On opening it up, what is the thermal paste for? Also, my first board was white, and this one is black. Not that I care about the color, but is ta a problem?


EDIT: Disregard. I see now. Also my original board is the same color.

Swapped in the new board, set up the parameters, and it did the same thing. The problem remains…

With what you’ve documented, it sounds like a super-noisy Makita router… I’d grab your longest extension cord and run a different phase outlet from somewhere to see if a more isolated router power source will mitigate your issue, You’ve got the latest/greatest CM controller and that’s got the latest noise suppression support.


Just ran it off a 100 foot extension from the other end of the house. Still dropped out.

I know you have tried many things but have you tried a different usb cable?

(edit) i see you did replace the usb cable a few days back…only other thing comes to mind is what will was saying about the brushes,motor could have collected somthing in the brushes,may be worth cleaning or replacing

1 Like

What Mark said - With the Makita AC source moved to that extreme I’d say it’s some other noise ingress locally… It’s corrupting your USB controller/hardware based on your port related error dialog.

I’m using a USB isolator into a 4-port hub connected to 2 CM controllers. I also have ferrite cores on all wiring to the controllers.


Brushes look new. They have less than an hour estimated total time on them.

1 Like

The piece the brushes rides against looks ok? the commutator i believe?? they are talking about brush wear in another thread Dewalt brush wear

and i agree andrew the brushes look new

1 Like

I really hope I don’t have to go that route. I’ve already sunk about 2 grand into this thing all together and I’m out of cash and haven’t really gotten it working right yet since unboxing. I can’t really afford to keep throwing money at it.

Do you have any links to your isolator? Model?

Sometimes troubleshooting the EMI gets down to the sort of black magic and voodoo which used to be necessary for SCSI connections.

Please try any combination of the following:

  • different router
  • different computer
  • different arrangement of plugs

If none of those work, please contact and we’ll see what we can do.

There are some models of the USB Isolator which have been noted as working for other customers listed on the wiki, but please try support first.

Copy Will. I have a support ticket in and I sent a summary update after trying the new board. I hope to hear back tomorrow. Unfortunately I don’t have another router to try. I ordered this machine on Thanksgiving as the package deal with the makkita router. My other router is a full size rigid so no dice there. :grinning:

I may have to order a makkita from home Depot or something. If it fixes it, I’ll return the other in the box. No shame there. This thing is like brand new. I don’t want to switch to the DeWalt because I got the eclair collets for the makkita.

1 Like

I believe I found your ticket, and hope that we can work it out — please let us know how things work out once they’re worked out!

Again, I had to use a powered USB hub into a USB isolator into a 1.5 foot standard USB cable into Shapeoko.

Here is the cable:
Monoprice 1.5-Feet USB 2.0 A Male to B Male 28/24AWG Cable (Gold Plated) (105436)

Here is the isolator:
SMAKN USB Isolator USB Digital Isolator Isolation USB to USB Industrial Isolator

1 Like

I have had “serial errors” errors with my Makita as well (I have the 230V version though). I bought it some weeks ago as an alternative to the Dewalt due to its lower RPM range, and the Dewalt never had this problem. Tried different things, but what seemed to solve the problem was connecting the Shapeoko and the laptop to a UPS (uninteruptable power supply) while keeping the Makita connected directly to the wall outlet. The UPS effectively keeps any noise on the HV circuit from reaching the controller/laptop through its inverter (at least the “online” kind which I use). Maybe worth trying…

1 Like

I think we are fixed now. Now more disconnects since adding the usb filter. I only finished the job and haven been able to get much time on it since due to work and sick kids/wife. I plan to try and cut some more tomorrow.

I’ll update later.

1 Like

Excellent news, Andrew. Glad the disconnects are mitigated.

1 Like

Definitely ground that spiral wire in the vacuum hose. I used one without a ground cleaning old insulation out of an attic and got a shock that was as bad as one coming from an electrical outlet. Better safe than sorry!!

1 Like