GRBL Panel failing every job

Trying to understand a grbl panel problem, when it’s worked well for things in the past. Since going to 1.1 on the controller, every job I try to run through it causes an immediate alarm and lock state. I home and zero before starting the job, same as I’ve done in the past
I’ve attached the gcode I’m trying (out of makercam) to flatten my worksurface. Feed and speed issues not withstanding, am I missing something simple? (8.8 KB)

Has Grbl Panel been updated to support Grbl 1.1?

The protocols are different, w/o explicit support for it, it won’t work.

v1.1 support was added to panel back in 2016, according to the release pages.

Maybe something to do with $130,131,132? I find when I have CM do a “send config” for the xxl, it populates these with values around 400mm, I assume because it’s sending coordinates in some special way, and not absolute? In grbl panel I enable soft limits, set those to the ~800mm actual values and jogging the machine behaves as expected.

Ok, got it, sort of: I had $20=1 to enable soft limits (to prevent crashes by my stupid self). Turned this off and now while the machine will happily run to it’s limits, my gcode runs exactly as expected.

Am I misunderstanding what soft/hard limits are?

It sounds like the soft limits are setting of the alarm like they should. When you updated to 1.1 your GRBL settings were set back to default, so you need to set $130 and $131 to your actual table dimensions, as it sounds like you are set to 400mm. If yo have an XL or XXL you need to increase the dimensions. I do not have GRBL Panel, so I can’t tell you how to do that.

1 Like

I agree something is funny with soft limits. It’s interesting that this isn’t enabled in grbl when CM is running it, but the machin still acts as though it’s got limits in place. An internal function of CM I guess?

Maybe my issue is misunderstanding zeroing vs offsets. I home my machine (back left). Then I jog it up to my front right where my cam paths origin is, and I zero out x and you, touch off and zero Z. Is this correct? Or Should my project origin always be home?

The final follow up question is a why CM sets the $13x values for the xxl to 400mm. Though even with them set to the correct ~800 values, soft limits don’t seem happy.