HDZ and $13 Setting

I purchased and installed an HDZ. I used Neil’s macros and worked with Neil to figure out the problem I was having to no avail. I would zero the the machine, run the initial macro, change a bit, run the change bit macro and the bit would be about 1/16" lower that the zero when the second bit cut. We tried a ton of variations to correct this issue and Neil suggested that it might be because I was running in inches instead of mm and be some sort of rounding error.

So in the the CNCjs console I changed it from inches to mm with no luck. At this point I was running a non-stock Z and had ordered the HDZ. I told Neil to wait till I put the HDZ on and we would see if it helped. So I installed it and it didnt help. However, I read Winston’s post on HDZ settings and changed some of my GRBL settings to match his recommendation. I had my $13 (Report inches, boolean) set to 1 to report in inches. It dawned on me that I might have misunderstood Neil’s questions earlier and changed this to $13=0 which is the default setting.

Sure enough the Bitsetter started working perfectly after this. I will do more testing to verify it is working before I start relying on it in production but I wanted to post this for anyone that may be struggling with this same issue as just quit trying to make it work.

Thanks to Neil for his patience and his dedication to the Carbide 3D community. I would have thrown the Bitsetter in the trash if he had not been willing to work with me over the last month to get this corrected.

3 Likes