HDZ not going full depth/Config Issue?

Hey guys, I’m working on a project tonight that I have cut before, and the depth of the carving was shallow. Thinking that maybe my spoilboard is due for a facing and was maybe off a little on one side of a longer project (16” wide on my XL), I decided to take the easy way out and just rezero my z axis by moving outside of the project and going below the zero plane like I’ve done before (essentially giving me a negative z value. However, when I got to about .226, it would not let me go any lower. Do I have something wrong in my settings? I did just upgrade to the proximity switches and a new control board, causing to me update to version 5 of carbide motion and sending a new configuration. I picked the config with the HDZ and the XL. In fact, I just did it again thinking this wasn’t correct since it showed the HDZ as 95 mm of travel. After resending, I’m still not able to jog any lower, and I do still have room on my HDZ. Thanks for the help!

are you sure your carriage was not hitting your dust hose and blocking?

1 Like

Good question, I didn’t think so but just checked with the hose off. It still stops. It definitely doesn’t seem like it’s fighting anything. Seems more like it’s hit a known limit and won’t go anymore.

so unless the bottom of the plate is reaching the end of the rails… it’s not the bottom

I have an earlier HDZ but I have no issues going through the bottom boards (don’t ask me how I know)

1 Like

Haha, I know the feeling! Do you happen to know what the “travel dimensions” show for you z axis on the settings display that I took an image of?

Mine shows
X 875
Y 425
Z 140

(sorry for the delay; my machine is in the basement and was not powered on)


Ha, no worries at all, I wouldn’t have worried if you could get to it right away. So, that makes more sense to me. Your Z shows about 2 inches more than mine (140 mm vs 95 mm). Story of my life ha. So, I would think that sending the correct config would fix that, but I’ve tried sending the XL with the HDZ multiple times and it keeps showing these numbers…and it does feel like I’m losing about those 2 inches. It must be something I’m doing wrong when I send the confirguration.

CM517 seems to have some issues with settings.

Please revert to CM513 if you can

In the meanwhile, set Z’s Travel to 140mm as @fenrus noted.

1 Like

Thanks Will, I suppose I didn’t necessarily think or know I could do that…just go ahead and manually enter 140 in the config screen that I showed? I’ll make the changes in the morning. Thanks a lot, fellas!

@fenrus Thanks a ton for your help in this as well, especially going out of your way to check your machine! I really appreciate it and know it took effort to help me out!

Is it possible it is hitting soft limit of project? Have you powered it off and reinitialized then try before loading gcode. My hdz can jog below the baseboard off the front of machine. Is your router all the way down on the mount?

1 Like

That’s a good thought as well, Guy. I’m hoping that the config will do the trick, but I will check this as well as I hadn’t thought of that. It is a project that I have run before, but the stock might be a different thickness. I created the project in vectric vcarve. I can’t think of a limit I would have in that program other than the retract z height limit. Good idea though, I’ll do some checking in the morning. Thanks!

If just entering 140 works then that’s fine — it may be that you need further settings in Grbl — we’ll be looking into that presently.

1 Like

I’m glad it wasn’t just me. I thought I was losing my mind last night. Haha
I reverted back to CM 513 and it fixed the issue.


Since I went from version 4.something to 5.17, I’m not sure I can get back to 5.13. However, I followed Will’s advice, plugged in 140 for my z axis, and I now have my full range of motion. Thanks again for everyone’s help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.