Hello Everyone, (new guy needs a little help)

Hi everyone,

just got my Shapoko Pro XXL setup last week. I decided to try and test today but I can’t seem to figure out why its not working correctly. here’s the back story and video. Im thinking its something I’m doing wrong, but I can’t for the life of me figure out what it is.

When I start up my machine I initialize and it all goes fine.

I set my bitzero V2 on the top my wood. I run it and zero out all 3 after its done.

next I load my file and hit run. It seems like the Z keeps going up and skips the homing device. Also, it seems like it would plunge into my piece of wood too deep. Hoping the video will help explain a little.

Anyway, thanks in advance.

If I get this right, you zero after using the Bit Zero… In my feeble, mind loading the file and start is the next step. If you zero after bit zero, I think you are zeroing at the height and location the router currently is.

I load a file, set zero by using Bit Zero, then start.

As for plunging, let’s see if it continues after the new process.

Good Luck
And have fun


The BitZero routine sets the zeroes for you.
As @Zman says, you don’t want to set your zeroes where the router ends up after the BitZero-ing.

I’m going to try it again tonight to see what happens.

1 Like

Also check you material height in you design program and your retract height

1 Like

At the 56 second mark it sounds like the Z axis was grinding, the machine has lost it’s Z position at that point.

Well, how did it go?

Still not right. I wonder if I didn’t set it up right. I been going over the instructions to make sure all my settings are right. It’s almost like my z isn’t right. It grinds before the start of every run. Homing it works right and all the sensors are working fine.

@Montezuma213 Can you share your gcode?

To second Neil’s request to have a look at your gcode and @Mogsy’s hunch: what value do you have your retract height set to ? The video really looks like what happens when setting a retract height that is greater than the available Z travel above the set zero. In that case, since the retract move is part of the actual job and limit switches are not active during a job (long story), if the gcode tells the machine to go higher than it actually can, it will try and do it, it will grind at the top of the Z axis (and then plunge too far into the wood, having lost its Z reference)

Either that or the gcode tells it to go to positive absolute Z, but there is no good reason for that


When I get home from vacation I will give that a look and share the CODE I think it was set to 2 inches for the retract hight. I just so happened to be looking at that. Is there a standard that everyone sets?, or is it based on the material?

It’s based on Workholding, based on what is safe/appropriate for the getting above clamps and so forth.

ok, just got home. I was able to stop the grinding on the machine. When I set the retract height to 1" it solved that issue. Now it seems like after I probe, the bit doesn’t come down far enough to reach my material. Here’s my steps and code.

  1. Initialize
  2. Load File
  3. Probe
  4. Run

Just a random question. I was looking at my setup papers and I don’t see where it says if I have a lead screw or ball screw? How can I tell? Wondering if maybe I didn’t set that right. I have it on lead screw for now.

Fixed File.nc (496.7 KB)

In that file you have the zero reference set to be at stock bottom, is this intentional ? If so, you cannot use the probe (at least for X/Y). If you want to use probing on the corner of the stock, you need to set your zero reference to “Zero height: Top” like so:


If you set your zero height to “bottom” and then probe on stock top, your toolpath will run in the air like you are probably seeing now.

The Shapeokos come with a “Z-plus” Z axis that is a leadscrew. “Ballscrew” is the type for the HDZ upgrade, so unless you got that, “leadscrew” is the correct setting for you

1 Like

thanks for the reply. let me change it and see what happens?

So now it looks like it would cut fine. Going to try a piece of MDF as my first test cut.


1 Like

Thanks Everyone! It seems to be working just fine now. made my first cut today.

1 Like