Help! ERROR (5) GRBL Error

Recently I’ve been generating a lot of toolpaths from complex vector geometries imported into fusion 360 from vector image programs like inkscape/illustrator. Fusion posts the code no problem, but every once in a while I get an error:

“Error (5): GRBL Error: The motion command has an invalid target. G2, G3, and G38.2 generates this error, if the arc is impossible to generate of if the probe target is the current position.”

Why would fusion program a toolpath arc that is impossible to generate?!?! I usually increase the toolpath “tolerance” and “smoothing” settings to the diameter of the tool, and the problem is solved, but not always. Also, increasing the tolerance and smoothing amount results in uglier/sloppier toolpaths.

What’s going on here? How can I fix this?


Ok, I turned off the “smoothing” and set the “tolerance” back to .001" and that seems to have solved the problem. (for now…):wink:


I’d also report it to autodesk, they may have an issue here where it’s generating an impossible toolpath. It’s not likely, but it could be. They’re pretty responsive to things they can reproduce.

1 Like

Updating for posterity, in case any lonesome soul ends up treading the same path I have. I’m happy to report I finally got to the bottom of things with regard to this problem.


Thanks for following up with this!