HELP! Machine has gone crazy!

Getting grbl codes along with blue and red flashing lights. I turn on the machine and do everything as usual and it’s fine. As soon as I load a file and go to cut it shoots to the back Right corner and makes horrendous noises. I am no where close to being tech savvy so please bare with me.

did you set a zero point?
(last time I forgot that… it did that)

Yes, I did everything as normally would.

Have you checked your limit switches? If they are not working correctly, the steppers will continue to rotate, resulting in skipped steps and a lot of noise.


I have checked them and I just know they ARE working just don’t know if working correctly or not.

Also unsure how to test if they are working correctly

This sounds like a zeroing issue.
Wheat software did you use to make your gcode, the file you load in Carbide Motion?
Can you share your gcode?
How, specifically, did you set your XY zero?

1 Like

I use Inkscape which is then transferred to carbide create, then carbide motion.
This same file I have been cutting on for a week and then all of a sudden today these problems arose. Again I’m nowhere near tech savvy so again please bare with me.
So everytime I will set my xyz accordingly to the pieces I have left from previous cuts (within this same project) and zero in depending on where my new piece sits which is almost always in the bottom left corner and I jog to the very corner of that and adjust z axis nearly to board using the paper trick and zeroing it all out.
Yes I will send that right now

AURA just your and is (260.3 KB)

Do have the new Shapeoko Pro Max? (I’m guessing that’ll be what they call it)
Your first move will be 70 inches to the right and about 4ft back.
Maybe a scaling issue? Check the dimensions in Create.

no i have the xxl and thats what my first guess was and figured through the whole updating software somewhere numbers got changed and i have no clue how to check or what i am even looking at with all that :confounded:

Someone that uses Create will chime in… Might help to share your file.

This is just a thought, but did you recently update carbide motion? Also do you set zero in the center, bottom left, or top left?

ahhhhh! im such an idiot. i just seen that in create on what i had thought was disabled is not which makes it up there off the grid which is making it chatter up and over. excuse me while i slap myself in the temple with a hammer :grimacing:

yes i did. i set zero most often in the bottom left corner

1 Like

This is just a hopeful thought, but maybe try downgrading versions? Not forever, but just to see if that’s what did it. But that does honestly sound like there is something wrong with the limit switches. Does the machine initialize fine?

I can’t tell if that response was sarcastic or the solution :joy:. Did you get it working?

lol no definitely the solution :woman_facepalming: if i had worked just a little slower i may have caught the mistake instead of blaming my machine, computer, etc. lol boy…its been a long unproductive day for me. i sure did install, uninstall, downgrade, upgrade software AT LEAST 6 times today. not to mention my machine has been calibrated at least 5 times and limit switches at least a million. so now that you and @neilferreri helped me realize i just needed to look at my work a little closer i should be all set and fine tuned :joy: thank you!

1 Like

I know it’s frustrating :joy: I’ve definitely had my fair share of those days. I’m glad you figured it out though! Best of luck with your project!

1 Like

if you don’;t know these tools yet, good to learn them:

  • online gcode viewer
  • Camotics - full gcode simulator

either would have shown this )