Help with edge Roundover for complex surfaces?

Hello,

I’m ripping out my hair over this. I’m trying to create a roundover in Carbide Create Pro. Before everyone jumps on me and says to use a router table or jam a roundover router bit in my spindle, hear me out. The surface I am trying to round over has several different heights. Routers and router tables do not accomodate such very well, and I do not know if it is possible to configure a tool path (in carbide) that would step down the Z axis where appropriate if I tried that.

I do realize that the 3d tools in pro are cludgy at best (when will we have the ability to edit components for all parameters instead of just the name, type, and base height instead of having to delete and recreate every time?), but I’m ALMOST there, and I just need this one thing to work. I almost have it working, the model seems to be correct, however when I set up toolpathing to cut the model, it does very funky things, and I believe this is because the model is not actually correct (See below)

This is what I’m trying to do. Please excuse the multiple posts and the links links, the forum only allows me to embed a single picture and two links per post (because reasons or national security is at stake! Or something).

I have this model:

I’m trying to round over the edge. These are the only parameters I found that get my close (stock height is 1.675")

This is the result:

It is sort of how I want, I can work with that, however note the weird geometry around the edges.

Please see the next post, as I can’t actually complete a thought and request actual assistance due to forum roles in a single post.

Now, when I DISABLE that edge view and create my toolpath, everything looks fine:

However, when I go back to model view, ENABLE the edge model and do nothing else (no new toolpaths for the edge or anything else), this is the result:

Obviously this screws up everything and the result is unusable.

Please help, I’m loosing my mind here. I’m sure it’s something simple but I’m stumped.

Thank you!