Help with Nomad Classic errors! Has been reflashed!

I have been having trouble with my machine and “limit switch” errors … I am new to this machine (recently Borrowed from a friend) … I ran several small projects with no problems but wanted to upgrade the software and so I reflashed the machine. The machine worked well after the upgrade as well!

The only recent change is to the material I am using? I had been making wood projects but recently switched to HDPE … ever since the machine has been acting up!

I can see the machine actually “Arc” as if it has a short before each failure … the arc appears in the lower left of the machine as seen from the front. it is where the spindle chassis frame meets the bed.

Is this repairable? do I need a new switch? I have seen other people having trouble because of grounding issues? Before I start ripping things up I would love the advice of anyone that knows more on the subject?

HDPE machining creates tremendous static. HDPE is plastic and even a piece laying a bench seems to charge up with static.

You may have an electrical problem check that out by unplugging and inspecting closely for loose connections.

Most likely it is just static and there are many threads about stopping static on Carbide3d machines.

Arc as electrical arcing ? :scream: …or just a mechanical glitch/jerk just before it stops ?

You lost me there, do you have a pic maybe of where you mean ?

You mention limit switch errors, could you post the exact error message you see reported ?

1 Like

Please contact us at support@carbide3d.com

Mention you have a Classic and send any photos which you think would be helpful.

Arc as in “stuck a fork in the outlet, good ole electrical arc” … I am seeing the flash in the seam where the upper framework and bed come together on the left-hand side looking in (As pointed out by my bear friend).

YES! I can’t believe I didn’t immediately recognize it as a static charge! I am old, my mind is slower than it once was … How to fix it is the next question? I didn’t find a plethora of threads detailing solutions … but again I am old and my not have been looking in the right places? I am hesitant to “Jerry” rig something that might make it worse if not done properly …

I am also hesitant to keep running it to repeat the error to take a pic of the specific message … it says, “Error, Limit switch hit” … I have found that if I unplug everything and let it sit awhile then start fresh it seems to work … If I rush it I get a code 43 error that says the machine cannot be found. And I am pretty sure I smoked one of the usb ports on my computer with the first big bang … only have so many more to risk :slight_smile:

This did not happen running wood projects so I am pretty sure it is related to the material and static! Now I have a starting point anyway! Thanks much!!

She is an old girl but new to me!

3 Likes

Then, most definitely what Will said (email support if not done already).
Serial number 0019…that’s a sweet vintage Nomad!

1 Like