Hitting left plate hard on rapid

after homing my shapeoko 3 xxl and clearing offsets if I rapid to any of the left points the X axis will hit the left plate hard all other rapid points work fine just the ones that send X to the far left.

Got a dust boot? You may need to adjust your machine limits because of it.
$130

1 Like

no dust boot yet have a Suck-it on order new user just getting started with my machine, how can I adjust my limits for rapids? shapeoko 3 xxl with 1.1 firmware

I don’t use Carbide Motion, so hopefully someone else will chime in.
If you send $$ through the MDI, it will report back your grbl settings.
$130 is the X max travel…you could adjust that.

That said, I’m not sure what CM actually sends for those rapid positions. Can you copy the log output when you do it and paste here?

1 Like

I will look at it the next time I am at the machine I am about ready to get off to bed atm but TY for the help so far

Those offsets are hard coded into CM4, no adjustments, but shouldn’t hit regardless. The only thing that comes to mind would be mechanical. If when your machine homes the limit switch is contacting something before truly being in the home position. That would make the machine “think” it’s at the far right mechanical limit, when in fact it isn’t. If that were the case then far left rapid positions would be outside the physical envelope of the machine, causing a crash. Is this crash new behavior, if so has something changed on your machine since? Is the homing switch hitting anything besides the right hand gantry plate while homing?

Dan

1 Like

@DanoInTx So that can’t be adjusted when your X-axis is reduced due to a dust boot or something?

Nope, which was a huge issue back at the time this update happened for those of us using the oldest version of the Suckit. Our machines would crash during rapids. The folks at Suckit redesigned their hardware to fix the issue, which wasn’t their issue to begin with (Thanks again for great service Suckit peeps!). For awhile I rolled my machine back to Grbl 0.9 and CM3. Then I got new dust shoe arms and flashed back to Grbl 1.1 and CM4 because of the new features (real-time feed/speed overrides, probing). I still like CM4, but it has some limits. I’ve tried several other alternatives, but I haven’t found one I’m really happy with. I’ve even considered dusting off my old coding skills and writing something I like, but too little time, too many other projects.

Dan

Here is a link to an old post. I had the same issue when I first got my XL.
Here was how I resolved the issue… hope it helps.

Tim

TJWTim

Dec '17

XXL expansion settings Shapeoko

I just finished assembly. I was having an issue after homing - the RPS that send the x axis to the left side of the machine caused it to crash into the rail. That was with 850x850 as the dimensions in the CM settings but the issue stopped when I changed to 835x835 as the dimensions. Anyone else have this issue? Am I missing something?

HI Tom-
I’m having the same issue with my XL
Crashing into left side when doing rapid position?
I feel better knowing I’m not the only one…

Tim

2 Likes

machine is new and it has done it from day 1 it works fine except for the rapid to the left side

The question then is if it’s actually reaching a far right homing position? Is the X homing switch being tripped before it reaches the right hand gantry plate (hitting belt clip, drag chain, etc…)? Are you using the latest Carbide Motion 4 with the latest Grbl 1.1? The limits set in CM4 are not adjustable (unless something has recently changed, which I doubt). Just checked mine as I type this, on home my carriage touches the right plate, then backs off the standard 5mm. On the left side doing a rapid I still have at least 10mm before hitting the left plate. This is with standard settings. I don’t know if it’s possible, but maybe also check that the homing switch plate is installed correctly (maybe there’s a way to make it stick out further and reach home sooner?). If it “thinks” it’s home, but it’s not actually far right, then during rapids it could hit.

Dan

yes using CM4 and and 1.1, the machine had the updated version on it when I received it as I got it in the 2018 black friday sale the switch hits the right plate as it should and backs off the proper amount 5 mm

Very odd.

This is what mine looks like:

Right hand side after homing, you can just barely make out the tip of the homing switch a few mm from the right hand plate:

Left hand side after rapid “NW” corner. Easily 10mm gap:

And (sorry about the crumby camera screen grab) the settings screen in Carbide Motion as they get sent to the controller (I have an XXL, but I don’t think it’s wider than the XL, just deeper). CM4.0.414

Just photos for comparison, maybe you’ll luck out and see something out of place? Other than that I’d ask C3D tech support?

Dan

1 Like

Please calibrate for belt tension:

Since the table sizes are hard-coded in CM4 you would need to adjust in some other way:

  • loosen hardware, pull into better alignment, tighten
  • reduce homing pull off in Grbl

Pretty much anything so long as you adjust where the switch is when it’s triggered.

Squaring the maching might help if it’s a lozenge shape which is shorter on X: https://wiki.shapeoko.com/index.php/Calibration_and_Squaring_the_Machine

Thanks Dan for posting your settings I checked it against mine and not sure why but when I initialized mine after the build both X and Y set to 850 so I put it on Shapeoko XXL and sent config data again and this time it set to the same as yours and my problem went away all is good now.

1 Like

I want to thank all that helped me here, I am new to the Shapeoko and this forum and happy to say you all made me feel at home here and treated me as an equal I hope I can in time help others as I learn more.

Cool deal @dps529 !! Glad it worked out. For some reason I thought you had an XL and not an XXL, so then my exact settings are applicable. Thing that’s bugging me now is actually 2 things:

  1. How did the wrong settings get stored in the first place? I don’t remember if those defaults have changed from earlier CM4 to the latest version, but I forget a lot these days, haha!!

  2. Why did the bed size setting being wrong cause the machine to overshoot? @WillAdams did the hard coded CM4 get changed recently to allow the Grbl settings to actually work? If so that’s awesome, if not then I’m confused :thinking:

Dan

I suspect the hard-coded numbers interact with the declared bed size — not sure what the result will be of such a change.

I am not sure how it happened cause my machine was shipped with 1.1 already on it I just followed the steps on building the machine and the initial setting to send the config data and that is what it did the first time after comparing your log I saw it was different and sent data again and it changed it to match yours.

I’m glad it’s all sorted!

I’m more confused about the bed size in Grbl affecting the rapid positions. That was exactly how it used to work with CM3 and Grbl 0.9. I’m not headed back out to the shop tonight, but perhaps tomorrow I’ll try a few things and see what does what. Thanks for the feedback!

Dan