Homing issue with X axis going wrong way

Hi there,
I just picked up a Shapeoko XXL at an Auction. I did some initial testing to make sure everything worked and it was. I then upgraded the GRBL firmware to 1.0 in order to use Carbide motion 5. Once completed, when I click initialize machine for homing, the X axis is opposite and go to the back left instead of back right. I had to turn the machine off because it limited out on the rail and I didn’t want to damage anything. I am a complete rookie and have no idea about code for the GRBL. Also, not sure if i need to reconfigure the limit switches after upgrading the firmware.
Any help is greatly appreciated.
Thank you!

first make sure the wires to the stepper aren’t wired “backwards”… that’s supposed to not be possible (the connectors are keyed but… with enough force pigs can fly)

there is a grbl setting ($3) that you can use to invert individual axis… but before mucking with that

in the MDI screen, can you type “$$” that should print all settings, and would be worth looking at setting 3 obviously


handy summary table for what $3 takes:

1 Like

Thank you! The wires aren’t crossed as the homing worked fine before I ungraded the firmware. As soon as I upgraded the GRBL, and tried homing in Carbide Motion 5, it was backwards. I’ll check the settings.


if you went from grbl 0.9 to 1.1 and you have one of those white color electronics boards, there might be another thing you need to do…
at least one generation of those boards has switches for each axis for step size, 1/4 and 1/8th

the 1.1 grbl needs this to be 1/8th. if this is wrong, you get all your dimensions off by a factor of 2 … (so easy to tell)

Those predated the XL and XXL machines, I think.
I’d like to know who’s still rocking one of the white PCBs! I had to give up on mine early as I couldn’t look at the machine without having an EMI based disconnect.

btw you can ask Carbide Motion to send all settings… if you haven’t done that since the firmware update it’s the easiest thing to try I suppose


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.