I am trying to us cncjs with my shapeoko pro

When I go to cut it cuts above my stock. I have checked my zero and it is right at my work piece. I am using 1 bit so that is not the problem. Thanks in advanced Hunter.

How high above your stock does the bit hover?
If it’s equal to your declared stock thickness you may have unintentionally selected stock bottom as the zero reference in your design file

It was only about .25 inches above. My stock is 1.5in thick. I manually leveled it and it ran fine. But when i use the bitzero it does not work.

Where did you put the BitZero on the stock, hanging of the corner or completely on top?

Which BitZero model do you have ? And since this thread is about your use of CNCjs, how are you using CNCjs for probing ?

The native probe module (Z only) has a “Touch Plate thickness” parameter that you must adjust to be the total thickness of the BitZero. Similarly if you are using Neil’s macros, you need to make sure the probe dimensions in the macro are correct.


I am using Neils macro. I assume the problem is that I did not change the probing tickness in the macro I have been using his macro. I have a bitzero v2

I am hanging it off the corner of my stock.

This topic was automatically closed after 30 days. New replies are no longer allowed.