I reset starting points in carbide motion and now I’m having troubles. Please help

I think I made a rookie mistake and I don’t know how to fix it. I was using carbide motion for my shapeoko XXL when I reset all of my zero points. Now, when I run the program after using my bit zero probe and hit start, the machine takes off to the top right corner and seems to crack in to the frame. How do I set up the proper starting points again? The machine seems to home properly to the top right corner. It seems to “initialize” just fine as well.

Thinks I’ve tried

  • I tried bringing the machine to where I wanted to start it and dropping my Z axis all the way down to the material. Then I reset all zeros and reset all offsets. Then I initialize the machine when it came up. No change. It’s still crashing into that corner.
  • I tried zeroing out all axis in the same position that I wanted to start in and then a resending configuration in the setting section.

I imagine I could just go back in and set up the machine as if it were brand new. I’ve been searching for the link for that and I can’t seem to find it.

Any help would be appreciated. I’m sure it’s a super easy fix and I’m just missing something.

Does the origin in the file match how you are setting zero relative to the stock?

Do you have some extra piece of geometry outside of the working area selected and included in a toolpath?

If you still can’t get it, please post the .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it, and a video showing what happens here, or to support@carbide3d.com and we’ll sort this out with you.

Thanks William.

I tried loading another small project and had the same issue. The piece is just taped down to my usual wasteboard I don’t think it’s a hidden piece of geometry but that is something I’ve done in the past. Haha. I was trying to max out the table with a 32 x 32 piece of 1/4” mdf for a stencil I was making. I couldn’t use my bitzero probe because I didn’t think it would be able to move far enough over to probe the X and Y positions, so I jogged the machine as far to the front left corner as I could. Then brought the Z axis down until it was about .5mm from the surface. I then reset all zero points. This is where my problem starts. I eventually wend back to this point and reset all offsets too. Then I went into “ machine position” and reset the zeros there. I’ve run another probe with the bitzero on each try. I decided to move the material over so it would work with the bitzero.

At this point I went to dr Internet and found that someone suggested in this scenario that I resend configuration in the settings bar. I did this to no avail. Then I went inside and watched an episode of cobra Kai on Netflix. That is where it stands now.

I honestly think it’s an operator error in resetting the starting point, but I can’t figure it out.

When you get strange behavior it never hurts to re-send the configuration. Also when you into jog you can go to rapid positions and have the router travel to your zero for x & y and 6MM above the Z zero.

That would tell you if your origin is set wrong. If the router moves to your zero position then you need to look at the file to see if something is wrong in there.

With the help of William, I was able to figure out that I was zeroing the location in the wrong place. I had to do the “hello world “ project again to get it back to where I wanted it. All seems to be well now except it keeps stopping in mud cut after about 8 or so minutes of cutting. Carbide motion seems to freeze up and I have to unplug the machine and close carbide motion so I can restart everything and then start again. I’ll look more into this in a bit.

The Carbide Motion problem is EMI disconnect.

Please let us know about this issue at support@carbide3d.com and we’ll work through this with you.