I'm new here and looking for some help

I am really liking all the capabilities of this software and can’t wait to learn more.

I am having a problem with my first project. I set up a project for my new LongMill and everything looks right but when I run the job the tool plunges in far below the top of the work surface. I have zeroed off the top of the work surface, and set the same in Carbide Create, I have the correct thickness in the job as well. I am sure its a setting issue somewhere but no idea where to look. I have been able to make other projects with things like Easel so I know the LongMill is functioning correctly.

Any help would be appreciated. Thanks.

Lou S

Which post-processor are you using?

Where do you have the origin set in the file?

Where are you setting it relative to the stock?

It may help to review:

If you continue to have difficulties, I’d suggest making a very simple project in both Easel and Carbide Create and posting them here.

I have selected GRBL as the post processor. In setup I have the Toolpath set to Lower-Left and the Stock Thickness is set to 0.719 and Zero Height is set to Top

OK Here are two simple job one created with Easel and one with Carbide Create.
Simple Square CC.nc (5.9 KB)
Square Easel.nc (10.2 KB)
When i run the visualizer in G-Sender the first thing the toolpath does with the file from CC is the plunge down the to the center of the earth (well, maybe thats an exaggeration)

Please post the .c2d file as well.

Also, step-by-step notes on how you are securing your stock and setting zero relative to them and how you are managing all tool changes.

Simple Square CC.c2d (44 KB)

For a machine interface I am running Gsender (the software from sienci) I am using their auto zero touchplate. Once I run that the tool moves to starting position at the lower left of the work piece so it appears that the zeroing in working just fine. When I run the file from Easel the tool raises up and moves to start the actual cutting. When I run the file form CC it plunges in and i have to hit the emergency stop button.

I have actually run the file with the machine off and watch the visualizer and the the tool plunges down like 5 inches from the zero position, moves to start cutting and then raises back up to actually cut the square.

I’m sure there is just a simple setting I am missing someplace.

I am securing the stock with clamps in a t-track and there are no tool changes being done.

Not seeing anything wrong in job setup:

and the preview seems fine:

Are you using “Carbide 3D Shapeoko” as a post-processor?

Note that that assumes one is using homing switches and that the machine can be moved in machine coordinates (G53 coordinate system):

(Move to safe Z to avoid workholding)
G53G0Z-0.197

You should use Grbl or Basic G-code, which instead output:

I am using GRBL as the post processor.

So, it appears that I was having an issue with zeroing. I reconnected to the machine and solved that. One other curious thing is that “move to safe Z” command where it sends the bit -0.197 which effectively sends the bit into the work before it moves to the first carving location. I ran the job with no bit and sure enough the z access dropped a little, moved to where it was going to start carving and then raised up the to the z safe to avoid hold downs. I actually just took the negative sign out and saved the file and it ran fine. It still doesn’t answer the question as to where that negative came from and if it will insert one later in a job if I was going to changed tools.

When using the Grbl post-processor I don’t see that:

G90
G21
(Toolpath....)
(Pocket.To...)
M05
M0 ;T102
M03S10000
G0X154.395Y70.655Z25.400
G1Z-1.270F203.2
X151.220F508.0
Y73.830

Interesting.

I am using the Carbide website the extract the Gcode since I am using new version that doesn’t export it. Every single one of the files I create has that -0.197 in it. Hmmmm

I’m pretty sure that tool is intended only for use by folks who own Carbide 3D machines, and that it defaults to (forces) the “Carbide 3D Shapeoko” post-processor.

If you don’t have a Carbide 3D machine or Pro license, I would suggest using v6:

I’ll give that a try