Is My Board Fried?

So I just finished a 45 minute cut, after removing the part and doing some cleanup I loaded another project. When I went to connect to Carbide Motion I get the following error:

GRBL error. Cutter not found

I tried restarting the computer, unplugging all of the cables from the board, resetting the board etc with absolutely no luck. I continue to get the same error no matter what I do. I am afraid that somehow my board is fried/toast/kaput. Any insight into anything else I should try? Any idea what could have caused this to happen? I have more jobs that I need to run so I cant afford for this thing to be down for long.

Thanks in advance for the help!

That sounds really strange. There is a reset button on the board, near the connectors if I remember correctly. Maybe try pressing that.

Assuming you re-start the Shapeoko check all the cables - and confirm you have a power light - right side near the limit switches.

Silly one, but on the power brick there is a switch on the cable - well worth checking it.

1 Like

I tried the reset button.

I checked all the cables and when I flip the switch on my power supply i can hear the stepper motors engage. After that I cant move the gantry at all like normal.

I dont have a switch on my cable, but like I said above I did make sure the switch was on on the power supply.

We have a basic article on this: — the only thing to add to that, esp. on a machine which was working but suddenly stopped is to

Trying a different machine / USB port / cable are obvious troubleshooting techniques — this stuff is so low voltage it seems to be delicate and vulnerable to ESD.

If none of the above pans out, contact — if you’re not using the e-mail address you ordered the machine from let us know serial # / order # and approx. when you ordered for warranty.

use a sketch to clear the EEPROM: and then reflash

This is a foreign language to me, lol.

I will try a different machine tonight and update this post.

1 Like

Had this happen to me. After replacing all of the above, it turned out that one of the stepper drivers overheated and burned. Check the PCB to make sure.

Sorry, the firmware which we use, Grbl, has at its heart an Arduino, a small single board computer often used for electronics projects.

There is a developer’s kit, and a special language, “Processing” for controlling it, and the programs are termed “Sketches” — you would go to the afore-mentioned link, install the SDK, d/l the program and then run it which would wipe your board — you could then reflash using our updater (it’s my understanding that the sketch is a more thorough erasure than merely reflashing)

I did look those over and did not see anything like that. I will double check again tonight.

Flip the USB port you’re using? Also try unplugging the power cord for the GRBL controller from the wall, then turn the in-line switch “on”. This should fully drain any residual juice in the caps and ps. Could be that it’s not allowing a full reset…

1 Like

Yeah the power brick seems to have enough residual power in it normally to briefly power up the motors, though he did say he unplugged the cables from the board. But yeah leave the brick plugged into the board not the wall and leave the switch on for a good 10 seconds to make sure it’s fully drained. Try another USB cable?

1 Like

I will see if I have another USB cable to try. Are these the same ones that work with computer printers? I know the one end is kinda funky.

It’s a standard USB A-B cable — the only unusual aspect should be on the newer machines where we’ve begun including one w/ ferrite beads.

I get that error all the time. It has to do with when you start the SO3 with when you start the software. I have found that I need to shut off and turn on the SO3 (with the switch on the cord) AFTER I start the software. I can also tell if its going to work because I get the “thunk” of the motor check immediately after flipping the switch. Sometime that thunk happens after about 10 seconds and I get the “cutter not found” error. Not sure if this is typical or not but it is my experience.

Try some different start and flip combinations and timings and Ill bet it goes away.

Good Luck!

Ha, I find I’m always better opening the software after the machine.

To tell you the truth, I am not 100% certain of the correct order. Usually, what happens is I try combinations until it works. The one thing I have captured is the “sound” of starting. I can tell if its going to work or not from the sound (and timing of the sound) the SO3 makes at power up.

Like I said before, I get the “thunk” of the motors engaging but it doesnt recognize the machine. i will try a few different combinations but i think i have tried what you are suggesting. Ill see if it works tonight.

Out of curiosity, are you using the same USB cable that was shipped with your Shapeoko? If not, how long is your USB cable that you replaced it with?

I am using the one that came with it.

If you do try a different USB cable, be sure the cable is less or equal than to 5 feet.

1 Like

I tried everything from new cables and different ports to using a completely different computer. I think the board was fried, but not sure why or how. I forgot that I had a replacement board and installed that(v2.3). Everything is running like new again. I am still stumped as to why or how the original board kicked the bucket.